lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Thu, 16 Jul 2009 08:58:04 -0600
From:	dann frazier <dannf@...nf.org>
To:	Yinghai Lu <yinghai@...nel.org>
Cc:	linux-kernel@...r.kernel.org
Subject: Re: [PATCH] [x86] pci: Get rid of magic number in AMD bus discovery

On Thu, Jul 16, 2009 at 03:09:22AM -0700, Yinghai Lu wrote:
> dann frazier wrote:
> > The number 4 is hardcoded in a couple of loops.
> > Use the already-defined PCI_ROOT_NR macro instead.
> > 
> > Signed-off-by: dann frazier <dannf@...com>
> > ---
> >  arch/x86/pci/amd_bus.c |    4 ++--
> >  1 files changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/arch/x86/pci/amd_bus.c b/arch/x86/pci/amd_bus.c
> > index 3ffa10d..feb3e09 100644
> > --- a/arch/x86/pci/amd_bus.c
> > +++ b/arch/x86/pci/amd_bus.c
> > @@ -332,7 +332,7 @@ static int __init early_fill_mp_bus_info(void)
> >  		return 0;
> >  
> >  	pci_root_num = 0;
> > -	for (i = 0; i < 4; i++) {
> > +	for (i = 0; i < PCI_ROOT_NR; i++) {
> >  		int min_bus;
> >  		int max_bus;
> >  		reg = read_pci_config(bus, slot, 1, 0xe0 + (i << 2));
> > @@ -368,7 +368,7 @@ static int __init early_fill_mp_bus_info(void)
> >  	memset(range, 0, sizeof(range));
> >  	range[0].end = 0xffff;
> >  	/* io port resource */
> > -	for (i = 0; i < 4; i++) {
> > +	for (i = 0; i < PCI_ROOT_NR; i++) {
> >  		reg = read_pci_config(bus, slot, 1, 0xc0 + (i << 3));
> >  		if (!(reg & 3))
> >  			continue;
> 
> please don't do that.
> 
> how about
>         /* mmio resource */
>         for (i = 0; i < 8; i++) {
> 
> those value is decided by HW...

Sorry, I don't follow.
My goal was just to remove the magic '4' number and replace it with a
macro instead - not to bump it up. PCI_ROOT_NR looked like the right
value (used in declaring the array we are indexing), but if not maybe
some other macro should be defined?

-- 
dann frazier

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ