[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090827115824.GA21882@redhat.com>
Date: Thu, 27 Aug 2009 14:58:24 +0300
From: "Michael S. Tsirkin" <mst@...hat.com>
To: Paolo Bonzini <bonzini@....org>
Cc: davidel@...ilserver.org, avi@...hat.com, gleb@...hat.com,
kvm@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/2] eventfd: reorganize the code to simplify new flags
On Thu, Aug 27, 2009 at 01:48:53PM +0200, Paolo Bonzini wrote:
> On 08/20/2009 05:57 PM, Michael S. Tsirkin wrote:
>> +static inline int eventfd_writeable(struct eventfd_ctx *ctx, u64 n)
>> +{
>> + return ULLONG_MAX - n> ctx->count;
>> +}
>> +
>> +static inline void eventfd_dowrite(struct eventfd_ctx *ctx, u64 ucnt)
>> +{
>> + if (eventfd_writeable(ctx, ucnt))
>> + ucnt = ULLONG_MAX - ctx->count;
>> +
>> + ctx->count += ucnt;
>
> In any case, this usage of eventfd_writeable is wrong: the code was like
> this:
>
> - if (ULLONG_MAX - ctx->count < n)
> - n = (int) (ULLONG_MAX - ctx->count);
> - ctx->count += n;
> + eventfd_dowrite(ctx, n);
>
> and so it should be !eventfd_writable. (This smelled when I was editing
> patch 2, so I went back and checked patch 1).
>
> Paolo
Right, patch 2 actually fixed this back. The best thing is to open-code
it actually, since we handle it in a way that only applies to a counter,
anyway. Will post a fixed v1.
--
MST
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists