lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 7 Sep 2009 09:38:34 +0200
From:	Nick Piggin <npiggin@...e.de>
To:	Daniel Walker <dwalker@...o99.com>
Cc:	linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [patch 16/33] fs: dcache per-bucket dcache hash locking

On Fri, Sep 04, 2009 at 07:51:37AM -0700, Daniel Walker wrote:
> On Fri, 2009-09-04 at 16:51 +1000, npiggin@...e.de wrote:
> > +/* This should be called _only_ with a lock pinning the dentry */
> > +static inline struct dentry * __dget_locked_dlock(struct dentry
> > *dentry)
> > +{
> > +       dentry->d_count++;
> > +       dentry_lru_del_init(dentry);
> > +       return dentry;
> > +}
> > +
> > +static inline struct dentry * __dget_locked(struct dentry *dentry)
> > +{
> 
> Could you run your series through checkpatch, and clean up at least any
> errors you find..

Sure, I'll try to remember to do that at some point. fs/ code has a lot of
space after *, which I don't always fix up (and arguably is a clearer way
write pointer types). But yeah I'm happy to follow checkpatch style.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ