[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20091202134645.GA19274@localhost>
Date: Wed, 2 Dec 2009 21:46:45 +0800
From: Wu Fengguang <fengguang.wu@...el.com>
To: Andi Kleen <andi@...stfloor.org>
Cc: Andrew Morton <akpm@...ux-foundation.org>,
Nick Piggin <npiggin@...e.de>,
"linux-mm@...ck.org" <linux-mm@...ck.org>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 12/24] HWPOISON: make it possible to unpoison pages
On Wed, Dec 02, 2009 at 09:15:30PM +0800, Andi Kleen wrote:
> > Note that it may leak pages silently - those who have been removed from
> > LRU cache, but not isolated from page cache/swap cache at hwpoison time.
>
> It would be better if we could detect that somehow and at least warn.
We warned when some page cannot be isolated (but didn't mention it may
lead to memory leak).
We exported the hwpoison counter in /proc/meminfo. The memory leak is
mainly a problem with stress testing, and the test cases can make use
of that counter to do sanity checking.
> > }
> >
> > +static int hwpoison_forget(void *data, u64 val)
> > +{
> > + if (!capable(CAP_SYS_ADMIN))
> > + return -EPERM;
> > +
> > + return forget_memory_failure(val);
> > +}
> > +
> > DEFINE_SIMPLE_ATTRIBUTE(hwpoison_fops, NULL, hwpoison_inject, "%lli\n");
> > +DEFINE_SIMPLE_ATTRIBUTE(unpoison_fops, NULL, hwpoison_forget, "%lli\n");
>
> I'll rename it to unpoison, not forget. I think that's a more clear
> name.
btw, do you feel comfortable with the interface name "renew-pfn"?
(versus "unpoison-pfn")
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists