[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20100106140035.6f622acf@jbarnes-piketon>
Date: Wed, 6 Jan 2010 14:00:35 -0800
From: Jesse Barnes <jbarnes@...tuousgeek.org>
To: "Rafael J. Wysocki" <rjw@...k.pl>
Cc: Matthew Garrett <mjg@...hat.com>, Len Brown <lenb@...nel.org>,
LKML <linux-kernel@...r.kernel.org>,
pm list <linux-pm@...ts.linux-foundation.org>,
Alan Stern <stern@...land.harvard.edu>,
ACPI Devel Maling List <linux-acpi@...r.kernel.org>,
Linux PCI <linux-pci@...r.kernel.org>,
Oliver Neukum <oliver@...kum.org>,
Bjorn Helgaas <bjorn.helgaas@...com>,
Shaohua Li <shaohua.li@...el.com>,
Francois Romieu <romieu@...zoreil.com>
Subject: Re: [PATCH 9/12] ACPI / PM: Introduce acpi_pm_wakeup_power()
On Sun, 27 Dec 2009 21:06:26 +0100
"Rafael J. Wysocki" <rjw@...k.pl> wrote:
> /**
> + * acpi_pm_wakeup_power - Enable/disable device wake-up power.
> + * @dev: ACPI device to handle.
> + * @enable: Whether to enable or disable the wake-up power of the
> device.
> + */
> +int acpi_pm_wakeup_power(struct acpi_device *dev, bool enable)
> +{
I know we've got these all over now, but functions that just take a
bool are generally hard to read when you just look at the call site.
If it was called "acpi_pm_set_wakeup_power" and then took an on/off
enum it would be really easy to see, from the callsite, what was going
on.
It's a fairly minor complaint, but it's something that's always bugged
me about the PCI PM code in particular.
--
Jesse Barnes, Intel Open Source Technology Center
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists