[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20100131183807.309a902f.akpm@linux-foundation.org>
Date: Sun, 31 Jan 2010 18:38:07 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: Alexey Dobriyan <adobriyan@...il.com>
Cc: Akinobu Mita <akinobu.mita@...il.com>,
linux-kernel@...r.kernel.org, Ingo Molnar <mingo@...e.hu>,
Peter Zijlstra <peterz@...radead.org>
Subject: Re: [PATCH 1/7] sched: Use for_each_bit
On Sun, 31 Jan 2010 14:06:10 +0200 Alexey Dobriyan <adobriyan@...il.com> wrote:
> On Sun, Jan 31, 2010 at 1:53 PM, Akinobu Mita <akinobu.mita@...il.com> wrote:
> > __#define for_each_cpupri_active(array, idx) __ __ __ __ __ __ __ __ __ __\
> > - __for (idx = find_first_bit(array, CPUPRI_NR_PRIORITIES); __ __ \
> > - __ __ __ idx < CPUPRI_NR_PRIORITIES; __ __ __ __ __ __ __ __ __ __ __ __ __ __\
> > - __ __ __ idx = find_next_bit(array, CPUPRI_NR_PRIORITIES, idx+1))
> > + __ __ __ for_each_bit(idx, array, CPUPRI_NR_PRIORITIES)
>
> It should be called for_each_set_bit().
Agree.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists