lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 31 Jan 2010 14:06:10 +0200
From:	Alexey Dobriyan <adobriyan@...il.com>
To:	Akinobu Mita <akinobu.mita@...il.com>
Cc:	linux-kernel@...r.kernel.org, Ingo Molnar <mingo@...e.hu>,
	Peter Zijlstra <peterz@...radead.org>
Subject: Re: [PATCH 1/7] sched: Use for_each_bit

On Sun, Jan 31, 2010 at 1:53 PM, Akinobu Mita <akinobu.mita@...il.com> wrote:
>  #define for_each_cpupri_active(array, idx)                    \
> -  for (idx = find_first_bit(array, CPUPRI_NR_PRIORITIES);     \
> -       idx < CPUPRI_NR_PRIORITIES;                            \
> -       idx = find_next_bit(array, CPUPRI_NR_PRIORITIES, idx+1))
> +       for_each_bit(idx, array, CPUPRI_NR_PRIORITIES)

It should be called for_each_set_bit().
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists