[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20100423021159.GF5600@nowhere>
Date: Fri, 23 Apr 2010 04:12:01 +0200
From: Frederic Weisbecker <fweisbec@...il.com>
To: Lin Ming <ming.m.lin@...el.com>
Cc: Peter Zijlstra <peterz@...radead.org>, Ingo Molnar <mingo@...e.hu>,
"eranian@...il.com" <eranian@...il.com>,
"Gary.Mohr@...l.com" <Gary.Mohr@...l.com>,
Corey Ashford <cjashfor@...ux.vnet.ibm.com>,
"arjan@...ux.intel.com" <arjan@...ux.intel.com>,
"Zhang, Yanmin" <yanmin_zhang@...ux.intel.com>,
Paul Mackerras <paulus@...ba.org>,
"David S. Miller" <davem@...emloft.net>,
lkml <linux-kernel@...r.kernel.org>
Subject: Re: [RFC][PATCH 1/4] perf: core, add group scheduling
transactional APIs
On Fri, Apr 23, 2010 at 10:08:25AM +0800, Lin Ming wrote:
> On Fri, 2010-04-23 at 01:31 +0800, Frederic Weisbecker wrote:
> > On Thu, Apr 22, 2010 at 03:51:02PM +0800, Lin Ming wrote:
> > > Add group scheduling transactional APIs to struct pmu.
> > > These APIs will be implemented in arch code, based on Peter's idea as
> > > below.
> > >
> > > > the idea behind hw_perf_group_sched_in() is to not perform
> > > > schedulability tests on each event in the group, but to add the group
> > > as
> > > > a whole and then perform one test.
> > > >
> > > > Of course, when that test fails, you'll have to roll-back the whole
> > > > group again.
> > > >
> > > > So start_txn (or a better name) would simply toggle a flag in the pmu
> > > > implementation that will make pmu::enable() not perform the
> > > > schedulablilty test.
> > > >
> > > > Then commit_txn() will perform the schedulability test (so note the
> > > > method has to have a !void return value, my mistake in the earlier
> > > > email).
> > > >
> > > > This will allow us to use the regular
> > > > kernel/perf_event.c::group_sched_in() and all the rollback code.
> > > > Currently each hw_perf_group_sched_in() implementation duplicates all
> > > > the rolllback code (with various bugs).
> > >
> > >
> > > Reviewed-by: Stephane Eranian <eranian@...gle.com>
> > > Reviewed-by: Peter Zijlstra <peterz@...radead.org>
> > > Signed-off-by: Lin Ming <ming.m.lin@...el.com>
> > > ---
> > > include/linux/perf_event.h | 8 +++++---
> > > kernel/perf_event.c | 29 ++++++++++++++++-------------
> > > 2 files changed, 21 insertions(+), 16 deletions(-)
> > >
> > > diff --git a/include/linux/perf_event.h b/include/linux/perf_event.h
> > > index ace31fb..b16cfba 100644
> > > --- a/include/linux/perf_event.h
> > > +++ b/include/linux/perf_event.h
> > > @@ -532,6 +532,8 @@ struct hw_perf_event {
> > >
> > > struct perf_event;
> > >
> > > +#define PERF_EVENT_TRAN_STARTED 1
> > > +
> > > /**
> > > * struct pmu - generic performance monitoring unit
> > > */
> > > @@ -542,6 +544,9 @@ struct pmu {
> > > void (*stop) (struct perf_event *event);
> > > void (*read) (struct perf_event *event);
> > > void (*unthrottle) (struct perf_event *event);
> > > + void (*start_txn) (const struct pmu *pmu);
> > > + void (*stop_txn) (const struct pmu *pmu);
> > > + int (*commit_txn) (const struct pmu *pmu);
> >
> >
> > Please add a few comments that briefly explain what these
> > *_txn callbacks are supposed to mean.
> >
> > Unless txn is an acronym that most kernel developers are used to.
>
> How about below changes?
>
> Thanks for review.
>
> diff --git a/include/linux/perf_event.h b/include/linux/perf_event.h
> index b16cfba..bba4c60 100644
> --- a/include/linux/perf_event.h
> +++ b/include/linux/perf_event.h
> @@ -544,9 +544,21 @@ struct pmu {
> void (*stop) (struct perf_event *event);
> void (*read) (struct perf_event *event);
> void (*unthrottle) (struct perf_event *event);
> - void (*start_txn) (const struct pmu *pmu);
> - void (*stop_txn) (const struct pmu *pmu);
> - int (*commit_txn) (const struct pmu *pmu);
> +
> + /*
> + * group events scheduling is treated as a transaction,
> + * add group events as a whole and perform one schedulability test.
> + * If test fails, roll back the whole group
> + */
> +
> + /* start group events transaction */
> + void (*start_group_trans) (const struct pmu *pmu);
> +
> + /* stop group events transaction */
> + void (*stop_group_trans) (const struct pmu *pmu);
> +
> + /* commit group events transaction */
> + int (*commit_group_trans) (const struct pmu *pmu);
> };
Looks good!
Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists