[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20100617203622.GB32523@kroah.com>
Date: Thu, 17 Jun 2010 13:36:22 -0700
From: Greg KH <greg@...ah.com>
To: Maurice Dawson <mauricedawson2699@...il.com>
Cc: gregkh@...e.de, wfp5p@...ginia.edu, stewart_r@...encamel.com,
devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] Staging: comedi: fix over 80 character coding style
issues in ni_labpc.c
On Sat, May 29, 2010 at 10:05:44AM +0100, Maurice Dawson wrote:
> This is a patch to the ni_labpc.c file that fixes most over 80 character warnings found by the checkpatch.pl tool. Two lines, 4 and 1035 have not been changed because readability is better and no information is hidden
>
> Signed-off-by: Maurice Dawson <mauricedawson2699@...il.com>
> ---
> drivers/staging/comedi/drivers/ni_labpc.c | 81 ++++++++++++++++++++---------
> 1 files changed, 57 insertions(+), 24 deletions(-)
>
> diff --git a/drivers/staging/comedi/drivers/ni_labpc.c b/drivers/staging/comedi/drivers/ni_labpc.c
> index 67c8a53..bf063ad 100644
> --- a/drivers/staging/comedi/drivers/ni_labpc.c
> +++ b/drivers/staging/comedi/drivers/ni_labpc.c
> @@ -738,7 +738,8 @@ static int labpc_attach(struct comedi_device *dev, struct comedi_devconfig *it)
> break;
> case pcmcia_bustype:
> printk
> - (" this driver does not support pcmcia cards, use ni_labpc_cs.o\n");
> + ("this driver does not support pcmcia cards, "
> + "use ni_labpc_cs.o\n");
Ick, no, don't break these types of strings. Newer versions of
checkpatch will not complain about this.
> if (mode == MODE_SINGLE_CHAN_INTERVAL) {
> if (cmd->chanlist_len > 0xff) {
> - comedi_error(dev,
> - "ni_labpc: chanlist too long for single channel interval mode\n");
> + comedi_error(dev, "ni_labpc: chanlist too long "
> + "for single channel "
> + "interval mode\n");
Same here, don't do this.
> return 1;
> }
> }
> @@ -881,23 +883,29 @@ static int labpc_ai_chanlist_invalid(const struct comedi_device *dev,
> switch (mode) {
> case MODE_SINGLE_CHAN_INTERVAL:
> if (CR_CHAN(cmd->chanlist[i]) != channel) {
> - comedi_error(dev,
> - "channel scanning order specified in chanlist is not supported by hardware.\n");
> + comedi_error(dev, "channel scanning order "
> + "specified in chanlist "
> + "is not supported "
> + "by hardware.\n");
Nor here.
> return 1;
> }
> break;
> case MODE_MULT_CHAN_UP:
> if (CR_CHAN(cmd->chanlist[i]) != i) {
> - comedi_error(dev,
> - "channel scanning order specified in chanlist is not supported by hardware.\n");
> + comedi_error(dev, "channel scanning order "
> + "specified in chanlist "
> + "is not supported "
> + "by hardware.\n");
Or here.
> return 1;
> }
> break;
> case MODE_MULT_CHAN_DOWN:
> if (CR_CHAN(cmd->chanlist[i]) !=
> cmd->chanlist_len - i - 1) {
> - comedi_error(dev,
> - "channel scanning order specified in chanlist is not supported by hardware.\n");
> + comedi_error(dev, "channel scanning order "
> + "specified in chanlist "
> + "is not supported "
> + "by hardware.\n");
Or here, or the rest of the printk() lines.
Care to resend this without those types of changes?
thanks,
greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists