[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.2.00.1010082015480.13094@localhost6.localdomain6>
Date: Fri, 8 Oct 2010 20:27:31 +0200 (CEST)
From: Thomas Gleixner <tglx@...utronix.de>
To: Andi Kleen <andi@...stfloor.org>
cc: torvalds@...ux-foundation.org, linux-kernel@...r.kernel.org,
Andi Kleen <ak@...ux.intel.com>, ralf@...ux-mips.org,
tony.luck@...el.com
Subject: Re: [PATCH] Define _addr_lsb in siginfo_t for mips and ia64
On Fri, 8 Oct 2010, Andi Kleen wrote:
> From: Andi Kleen <ak@...ux.intel.com>
>
> Define an _addr_lsb field in the mips and ia64 siginfo_ts, following
> the asm-generic version. This just puts the field over padding.
>
> This fixes a compilation problem introduced with a337fda.
But it does not fix the mess you created in kernel/signal.c (aside of
the completely braindaed #ifdef, it's whitespace damaged) with a two
days old patch which has neither seen next, nor been reviewed by
people who care about core code nor been cross-compiled which is
mandatory for core kernel code changes.
The correct fix is to revert the patch in kernel/signal.c and fix this
proper in .37. This put_user is missing since .32 when you introduced
that grossly misnamed si extension, so there is no rush to get this in
during the late -rc cycle.
Thanks
tglx
> Cc: ralf@...ux-mips.org
> Cc: tony.luck@...el.com
> Signed-off-by: Andi Kleen <ak@...ux.intel.com>
> ---
> arch/ia64/include/asm/siginfo.h | 1 +
> arch/mips/include/asm/siginfo.h | 1 +
> 2 files changed, 2 insertions(+), 0 deletions(-)
>
> diff --git a/arch/ia64/include/asm/siginfo.h b/arch/ia64/include/asm/siginfo.h
> index 118d429..d20bf96 100644
> --- a/arch/ia64/include/asm/siginfo.h
> +++ b/arch/ia64/include/asm/siginfo.h
> @@ -62,6 +62,7 @@ typedef struct siginfo {
> int _imm; /* immediate value for "break" */
> unsigned int _flags; /* see below */
> unsigned long _isr; /* isr */
> + short _addr_lsb;
> } _sigfault;
>
> /* SIGPOLL */
> diff --git a/arch/mips/include/asm/siginfo.h b/arch/mips/include/asm/siginfo.h
> index 96e28f1..709f7d4 100644
> --- a/arch/mips/include/asm/siginfo.h
> +++ b/arch/mips/include/asm/siginfo.h
> @@ -88,6 +88,7 @@ typedef struct siginfo {
> #ifdef __ARCH_SI_TRAPNO
> int _trapno; /* TRAP # which caused the signal */
> #endif
> + short _addr_lsb;
> } _sigfault;
>
> /* SIGPOLL, SIGXFSZ (To do ...) */
> --
> 1.7.1
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at http://www.tux.org/lkml/
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists