[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1287424542.20968.121.camel@Joe-Laptop>
Date: Mon, 18 Oct 2010 10:55:42 -0700
From: Joe Perches <joe@...ches.com>
To: Julia Lawall <julia@...u.dk>
Cc: walter harms <wharms@....de>, devel@...verdev.osuosl.org,
gregkh@...e.de, kernel-janitors@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/3] drivers/staging/cx25821: Use kstrdup
On Mon, 2010-10-18 at 19:44 +0200, Julia Lawall wrote:
> On Mon, 18 Oct 2010, Joe Perches wrote:
>
> > Perhaps it's more readable code to recheck the
> > field name flag and introduce a temporary
> > char *fname so the slightly unusual reuse of
> > field = kstrdup(field, GFP)
> > becomes
> > field = kstrdup(fname, GFP)
>
> Before I had a local variable filename. I preferred that because I felt
> uneasy about putting both statically and dynamically allocated memory in
> the same field. But it does mean adding a new local variable.
I think readability is better using a temporary.
> I'm not sure to understand "recheck the field name flag", though.
Sorry, poor wording. I meant using this style:
if (field && *field)
foo
else if (field)
bar
else
baz
instead of:
if (field) {
if (*field)
foo
else
bar
} else
baz
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists