lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 20 Oct 2010 12:52:03 -0700
From:	Joe Perches <joe@...ches.com>
To:	Jean Delvare <khali@...ux-fr.org>
Cc:	dave@....org, Guenter Roeck <guenter.roeck@...csson.com>,
	Hans de Goede <j.w.r.degoede@....nl>,
	Alistair John Strachan <alistair@...zero.co.uk>,
	Henrik Rydberg <rydberg@...omail.se>,
	"Mark M. Hoffman" <mhoffman@...htlink.com>,
	Luca Tettamanti <kronos.it@...il.com>,
	Fenghua Yu <fenghua.yu@...el.com>,
	Juerg Haefliger <juergh@...il.com>,
	Eric Piel <eric.piel@...mplin-utc.net>,
	Jim Cromie <jim.cromie@...il.com>,
	Roger Lucas <vt8231@...denengine.co.uk>,
	lm-sensors@...sensors.org, LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] drivers/hwmon: Use pr_fmt and pr_<level>

On Wed, 2010-10-20 at 21:38 +0200, Jean Delvare wrote:
> On Wed, 20 Oct 2010 16:19:46 -0300, Davidlohr Bueso wrote:
> > Well we do have this:
> > #ifndef pr_fmt
> > #define pr_fmt(fmt) fmt
> > #endif
> I can read the code, thank you. My point is that what we have is
> insufficient, as Joe is proposing to use a different pr_fmt definition
> for pretty much all drivers in the kernel tree.

No, I'm proposing to use a uniform pr_fmt definition for
files that want a prefix on their logging messages.

At some point, the files that do not want a prefix
should be converted to use #define pr_fmt(fmt) fmt.

Repeating from another email, there are ~1500 files that
use pr_<level> without using pr_fmt.  There are 335 files
that #define pr_fmt.

So I'm not saying that point in time is now.

Another way to do this would be to standardize
hwmon.h so it would add:
	"#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt"
in only 1 place.

So perhaps add this to include/linux/hwmon.h instead:

#if defined pr_fmt
#undef pr_fmt
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
#endif


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ