lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 3 Jan 2011 21:05:24 +0100
From:	Uwe Kleine-König 
	<u.kleine-koenig@...gutronix.de>
To:	Axel Lin <axel.lin@...il.com>
Cc:	linux-kernel@...r.kernel.org, Samuel Ortiz <sameo@...ux.intel.com>
Subject: Re: [PATCH] mfd: Move error handling to the end of mc13xxx_probe

On Mon, Jan 03, 2011 at 05:36:59PM +0800, Axel Lin wrote:
> To improve readability, move error handling to the end of mc13xxx_probe.
I like the way it was done before (obviously as I wrote the code).
Though I don't feel strongly against the move.  Still I prefer the more
explicit error labels.

On a scale between -1 and 1 it would get a -0 from me.

Best regards
Uwe
 
> Signed-off-by: Axel Lin <axel.lin@...il.com>
> ---
>  drivers/mfd/mc13xxx-core.c |   22 ++++++++++------------
>  1 files changed, 10 insertions(+), 12 deletions(-)
> 
> diff --git a/drivers/mfd/mc13xxx-core.c b/drivers/mfd/mc13xxx-core.c
> index b9fcaf0..18c29fc 100644
> --- a/drivers/mfd/mc13xxx-core.c
> +++ b/drivers/mfd/mc13xxx-core.c
> @@ -732,28 +732,21 @@ static int mc13xxx_probe(struct spi_device *spi)
>  
>  	ret = mc13xxx_identify(mc13xxx, &id);
>  	if (ret || id == MC13XXX_ID_INVALID)
> -		goto err_revision;
> +		goto err;
>  
>  	/* mask all irqs */
>  	ret = mc13xxx_reg_write(mc13xxx, MC13XXX_IRQMASK0, 0x00ffffff);
>  	if (ret)
> -		goto err_mask;
> +		goto err;
>  
>  	ret = mc13xxx_reg_write(mc13xxx, MC13XXX_IRQMASK1, 0x00ffffff);
>  	if (ret)
> -		goto err_mask;
> +		goto err;
>  
>  	ret = request_threaded_irq(spi->irq, NULL, mc13xxx_irq_thread,
>  			IRQF_ONESHOT | IRQF_TRIGGER_HIGH, "mc13xxx", mc13xxx);
> -
> -	if (ret) {
> -err_mask:
> -err_revision:
> -		mc13xxx_unlock(mc13xxx);
> -		dev_set_drvdata(&spi->dev, NULL);
> -		kfree(mc13xxx);
> -		return ret;
> -	}
> +	if (ret)
> +		goto err;
>  
>  	mc13xxx_unlock(mc13xxx);
>  
> @@ -785,6 +778,11 @@ err_revision:
>  	}
>  
>  	return 0;
> +err:
> +	mc13xxx_unlock(mc13xxx);
> +	dev_set_drvdata(&spi->dev, NULL);
> +	kfree(mc13xxx);
> +	return ret;
>  }
>  
>  static int __devexit mc13xxx_remove(struct spi_device *spi)
> -- 
> 1.7.2
> 
> 
> 
> 

-- 
Pengutronix e.K.                           | Uwe Kleine-König            |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ