[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110217172559.GD17058@elte.hu>
Date: Thu, 17 Feb 2011 18:25:59 +0100
From: Ingo Molnar <mingo@...e.hu>
To: Jan Beulich <JBeulich@...ell.com>
Cc: tglx@...utronix.de, hpa@...or.com, tony.luck@...el.com,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/3] x86-64: use relative 32-bit pointers in exception
tables
Nice patch. I've got a really small code readability nitpick:
> +#ifndef ex_insn /* until all architectures have this accessor */
> +#define ex_insn(x) (x)->insn
> +#endif
> +#else
> +#define swap_ex NULL
> +#endif
In the x86 architecture we tend to write this as:
> +#else
> +# define swap_ex NULL
> +#endif
So that the conditional structure stands out more, visually. (There might be more
such cases in these patches as well.)
Thanks,
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists