lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 8 Apr 2011 15:01:57 -0700
From:	Greg KH <greg@...ah.com>
To:	Rafał Miłecki <zajec5@...il.com>
Cc:	linux-wireless@...r.kernel.org,
	"John W. Linville" <linville@...driver.com>,
	George Kashperko <george@...u.edu.ua>,
	Arnd Bergmann <arnd@...db.de>,
	Russell King <rmk@....linux.org.uk>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	b43-dev@...ts.infradead.org,
	Michael Büsch <mb@...sch.de>,
	linuxdriverproject <devel@...uxdriverproject.org>,
	"linux-arm-kernel@...ts.infradead.org" 
	<linux-arm-kernel@...ts.infradead.org>,
	Larry Finger <Larry.Finger@...inger.net>
Subject: Re: [RFC][WAS:bcmai][PATCH V2] axi: add AXI bus driver

On Fri, Apr 08, 2011 at 09:45:00PM +0200, Rafał Miłecki wrote:
> Cc: Michael Büsch <mb@...sch.de>
> Cc: Larry Finger <Larry.Finger@...inger.net>
> Cc: George Kashperko <george@...u.edu.ua>
> Cc: Arend van Spriel <arend@...adcom.com>
> Cc: linux-arm-kernel@...ts.infradead.org <linux-arm-kernel@...ts.infradead.org>
> Cc: Russell King <rmk@....linux.org.uk>
> Cc: Arnd Bergmann <arnd@...db.de>
> Cc: linuxdriverproject <devel@...uxdriverproject.org>
> Cc: linux-kernel@...r.kernel.org <linux-kernel@...r.kernel.org>
> Signed-off-by: Rafał Miłecki <zajec5@...il.com>
> ---
> This is second try for introducing new bus driver.
> V2: Rename to axi
>     Use DEFINE_PCI_DEVICE_TABLE in bridge
>     Make use of pr_fmt and pr_*
>     Store core class
>     Rename bridge to not b43 specific
>     Replace magic 0x1000 with BCMAI_CORE_SIZE
>     Remove some old "ssb" names and defines
>     Move BCMAI_ADDR_BASE def
>     Add drvdata field
> TODO:
> - Interrupts
> - Reloading driver

Please add to the TODO list:
	- Documentation/ABI entries for new sysfs files
	- proper Kconfig entry documentation for the different options
	- remove unneeded pcicore_write* wrapper functions that do
	  nothing.


> +static void axi_release_core_dev(struct device *dev)
> +{
> +	kfree(dev);
> +}

This is wrong, unless you are really only creating a 'struct device'.
Why are you doing that instead of embedding struct device in your
structure?

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ