[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110802185530.GH6399@redhat.com>
Date: Tue, 2 Aug 2011 14:55:30 -0400
From: Vivek Goyal <vgoyal@...hat.com>
To: Michael Holzheu <holzheu@...ux.vnet.ibm.com>
Cc: ebiederm@...ssion.com, mahesh@...ux.vnet.ibm.com, hbabu@...ibm.com,
oomichi@....nes.nec.co.jp, horms@...ge.net.au,
schwidefsky@...ibm.com, heiko.carstens@...ibm.com,
kexec@...ts.infradead.org, linux-kernel@...r.kernel.org,
linux-s390@...r.kernel.org
Subject: Re: [patch v2 02/10] kdump: Make kimage_load_crash_segment() weak
On Tue, Aug 02, 2011 at 11:30:03AM +0200, Michael Holzheu wrote:
> Hello Vivek,
>
> On Mon, 2011-08-01 at 16:31 -0400, Vivek Goyal wrote:
> > On Wed, Jul 27, 2011 at 02:55:06PM +0200, Michael Holzheu wrote:
>
> [snip]
>
> > > --- a/kernel/kexec.c
> > > +++ b/kernel/kexec.c
> > > @@ -842,8 +842,8 @@ out:
> > > return result;
> > > }
> > >
> > > -static int kimage_load_crash_segment(struct kimage *image,
> > > - struct kexec_segment *segment)
> > > +int __weak kimage_load_crash_segment(struct kimage *image,
> > > + struct kexec_segment *segment)
> >
> > A comment here why we are making it weak should help in increasing
> > the code readability.
>
> What about the following:
>
> /*
> * Load crash segment into memory. Architecture code can override this
> * function. E.g. this is necessary for architectures that do not
> * create page tables for crashkernel memory.
> */
> int __weak kimage_load_crash_segment(struct kimage *image,
This looks better.
Thanks
Vivek
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists