[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110823165453.GB23870@redhat.com>
Date: Tue, 23 Aug 2011 18:54:53 +0200
From: Andrea Arcangeli <aarcange@...hat.com>
To: Minchan Kim <minchan.kim@...il.com>
Cc: Michel Lespinasse <walken@...gle.com>,
Andrew Morton <akpm@...ux-foundation.org>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org, Hugh Dickins <hughd@...gle.com>,
Johannes Weiner <jweiner@...hat.com>,
Rik van Riel <riel@...hat.com>, Mel Gorman <mgorman@...e.de>,
KOSAKI Motohiro <kosaki.motohiro@...fujitsu.com>,
Shaohua Li <shaohua.li@...el.com>
Subject: Re: [PATCH] thp: tail page refcounting fix
On Wed, Aug 24, 2011 at 01:45:15AM +0900, Minchan Kim wrote:
> Nice idea!
Thanks! It felt natural to account the tail refcounts in
page_tail->_count, so they were already there and it was enough to add
the page_mapcount(head_page) to the page_tail->_count. But there's no
particular reason we had to do the tail_page refcounting in the
->_page field before the split...
> Reviewed-by: Minchan Kim <minchan.kim@...il.com>
>
> The code looks good to me.
Thanks a lot for the quick review.
> The nitpick is about naming 'foll'.
> What does it mean? 'follow'?
> If it is, I hope we use full name.
> Regardless of renaming it, I am okay the patch.
Ok the name comes from FOLL_GET. Only code paths marked by checking
FOLL_GET are allowed to call get_page_foll(). Anything else can't.
mm/*memory.c:
if (flags & FOLL_GET)
get_page_foll(page);
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists