[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <4E987310.1050401@pobox.com>
Date: Fri, 14 Oct 2011 13:36:16 -0400
From: Jeff Garzik <jgarzik@...ox.com>
To: Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
CC: linux-ide@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 3/4] ata_piix: CodingStyle fixes
On 10/13/2011 09:43 AM, Bartlomiej Zolnierkiewicz wrote:
> From: Bartlomiej Zolnierkiewicz<bzolnier@...il.com>
> Subject: [PATCH] ata_piix: CodingStyle fixes
>
> CodingStyle fixes for piix_port_info[].
>
> Signed-off-by: Bartlomiej Zolnierkiewicz<bzolnier@...il.com>
> ---
> drivers/ata/ata_piix.c | 68 ++++++++++++++-----------------------------------
> 1 file changed, 20 insertions(+), 48 deletions(-)
>
> Index: b/drivers/ata/ata_piix.c
> ===================================================================
> --- a/drivers/ata/ata_piix.c
> +++ b/drivers/ata/ata_piix.c
> @@ -473,131 +473,103 @@ static const struct piix_map_db *piix_ma
> };
>
> static struct ata_port_info piix_port_info[] = {
> - [piix_pata_mwdma] = /* PIIX3 MWDMA only */
> - {
> + [piix_pata_mwdma] = { /* PIIX3 MWDMA only */
> .flags = PIIX_PATA_FLAGS,
> .pio_mask = ATA_PIO4,
> - .mwdma_mask = ATA_MWDMA12_ONLY, /* mwdma1-2 ?? CHECK 0 should be ok but slow */
> + .mwdma_mask = ATA_MWDMA12_ONLY, /* check if MWDMA0 is OK */
> .port_ops =&piix_pata_ops,
> },
Having been the perpetrator of this "awful" coding style, I think it is
fine and more readable as-is... :)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists