[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4EEEF68D.9000908@redhat.com>
Date: Mon, 19 Dec 2011 10:32:13 +0200
From: Avi Kivity <avi@...hat.com>
To: Takuya Yoshikawa <yoshikawa.takuya@....ntt.co.jp>
CC: Xiao Guangrong <xiaoguangrong@...ux.vnet.ibm.com>,
Marcelo Tosatti <mtosatti@...hat.com>,
LKML <linux-kernel@...r.kernel.org>, KVM <kvm@...r.kernel.org>
Subject: Re: [PATCH 3/8] KVM: MMU: do not add a nonpresent spte to rmaps of
its child
On 12/19/2011 04:39 AM, Takuya Yoshikawa wrote:
> (2011/12/16 19:15), Xiao Guangrong wrote:
>
>> -static void mmu_page_add_parent_pte(struct kvm_vcpu *vcpu,
>> - struct kvm_mmu_page *sp, u64 *parent_pte)
>> +static void mmu_page_add_set_parent_pte(struct kvm_vcpu *vcpu,
>> + struct kvm_mmu_page *sp,
>> + u64 *parent_pte)
>> {
>> if (!parent_pte)
>> return;
>>
>> + mmu_spte_set(parent_pte, __pa(sp->spt) | SHADOW_PAGE_TABLE);
>> pte_list_add(vcpu, parent_pte,&sp->parent_ptes);
>> }
>
> There are a few prefixes in the kvm mmu code.
>
> e.g. mmu_page_, kvm_mmu_, kvm_mmu_page_, ...
>
> Sometimes we also use "sp".
>
> How about deciding a consistent way from now on?
>
In general I am in favour of consistency, but I'm not inviting
mass-renaming patches. Let's try to be consistent in new patches (like
your suggestions on this patchset).
> E.g.
> if the function is static and for local use only, such a prefix
> can be eliminated,
>
> if it is used outside of mmu.c, kvm_mmu_ is needed,
>
> we use sp for kvm_mmu_page,
> ...
--
error compiling committee.c: too many arguments to function
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists