[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20120320163922.GA24462@infradead.org>
Date: Tue, 20 Mar 2012 12:39:22 -0400
From: Christoph Hellwig <hch@...radead.org>
To: Miklos Szeredi <miklos@...redi.hu>
Cc: viro@...IV.linux.org.uk, linux-fsdevel@...r.kernel.org,
linux-kernel@...r.kernel.org, hch@...radead.org, mszeredi@...e.cz
Subject: Re: [PATCH 8/9] vfs: split __lookup_hash
On Tue, Mar 06, 2012 at 01:56:40PM +0100, Miklos Szeredi wrote:
> From: Miklos Szeredi <mszeredi@...e.cz>
>
> Split __lookup_hash into two component functions:
>
> lookup_dcache - tries cached lookup, returns whether real lookup is needed
> lookup_real - calls i_op->lookup
>
> This eliminates code duplication between d_alloc_and_lookup() and
> d_inode_lookup().
The return value from lookup_dcache is a bit confusing. What about
returning the need_lookup flag, and passing the dentry as a parameter,
that way the callers would do the more obvious:
if (lookup_dcache(name, base, nd, &dentry))
return dentry;
instead of having to check two conditions.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists