[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.2.02.1206041228330.3086@ionos>
Date: Mon, 4 Jun 2012 12:32:50 +0200 (CEST)
From: Thomas Gleixner <tglx@...utronix.de>
To: "Srivatsa S. Bhat" <srivatsa.bhat@...ux.vnet.ibm.com>
cc: Sam Ravnborg <sam@...nborg.org>, peterz@...radead.org,
paulmck@...ux.vnet.ibm.com, rusty@...tcorp.com.au,
mingo@...nel.org, yong.zhang0@...il.com, akpm@...ux-foundation.org,
vatsa@...ux.vnet.ibm.com, rjw@...k.pl, linux-arch@...r.kernel.org,
linux-kernel@...r.kernel.org, nikunj@...ux.vnet.ibm.com,
Suresh Siddha <suresh.b.siddha@...el.com>,
Venkatesh Pallipadi <venki@...gle.com>
Subject: Re: [PATCH 01/27] smpboot: Provide a generic method to boot secondary
processors
On Sat, 2 Jun 2012, Srivatsa S. Bhat wrote:
> On 06/01/2012 10:21 PM, Sam Ravnborg wrote:
>
> >> +/* Implement the following functions in your architecture, as appropriate. */
> >> +
> >> +/**
> >> + * __cpu_pre_starting()
> >> + *
> >> + * Implement whatever you need to do before the CPU_STARTING notifiers are
> >> + * invoked. Note that the CPU_STARTING callbacks run *on* the cpu that is
> >> + * coming up. So that cpu better be prepared! IOW, implement all the early
> >> + * boot/init code for the cpu here. And do NOT enable interrupts.
> >> + */
> >> +#ifndef __cpu_pre_starting
> >> +void __weak __cpu_pre_starting(void *arg) {}
> >> +#endif
This wants to be a prototype w/o the __weak prefix and the #ifndef
magic and the weak default implementation should be in kernel/smpboot.c
> > __What __is __the __purpose __of __all __these __underscaores __used
> > __as __function __prefix? __It __does __not __help __readability.
>
> >
>
>
> We had used "__" as the function prefix to emphasize that these functions are
> implemented/overriden in the depths of architecture-specific code.
>
> But now that you mention it, I see that we don't really have something like an
> arch-independent variant without the "__" prefix. So adding the "__" prefix
> might not be really necessary, since there is nothing to distinguish name-wise.
>
> However, I do want to emphasize that this isn't generic code. So how about
> an "arch_" prefix instead? Something like:
> arch_cpu_pre_starting(), arch_cpu_pre_online() and arch_cpu_post_online()?
Yes, please.
Otherwise, thanks for that work! From the first glance, it's not
colliding much with the changes I have in the pipeline, but I will
have a closer look.
Thanks,
tglx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists