[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20121031010232.GA18229@leaf>
Date: Tue, 30 Oct 2012 18:02:32 -0700
From: Josh Triplett <josh@...htriplett.org>
To: Borislav Petkov <bp@...en8.de>,
Daniel Santos <daniel.santos@...ox.com>,
LKML <linux-kernel@...r.kernel.org>,
Andi Kleen <ak@...ux.intel.com>,
Andrea Arcangeli <aarcange@...hat.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Christopher Li <sparse@...isli.org>,
David Daney <david.daney@...ium.com>,
David Howells <dhowells@...hat.com>,
Joe Perches <joe@...ches.com>,
Konstantin Khlebnikov <khlebnikov@...nvz.org>,
linux-sparse@...r.kernel.org,
Michel Lespinasse <walken@...gle.com>,
Paul Gortmaker <paul.gortmaker@...driver.com>,
Pavel Pisa <pisa@....felk.cvut.cz>,
Peter Zijlstra <a.p.zijlstra@...llo.nl>,
Steven Rostedt <rostedt@...dmis.org>,
David Rientjes <rientjes@...gle.com>
Subject: Re: [PATCH v4 9/9] bug.h: Convert BUILD_BUG{,_ON} to use
BUILD_BUG_ON_MSG
On Tue, Oct 30, 2012 at 08:19:05PM +0100, Borislav Petkov wrote:
> On Sun, Oct 28, 2012 at 03:57:15PM -0500, danielfsantos@....net wrote:
> > Remove duplicate code by converting BUILD_BUG and BUILD_BUG_ON to just
> > call BUILD_BUG_ON_MSG. This not only reduces source code bloat, but
> > also prevents the possibility of code being changed for one macro and
> > not for the other (which was previously the case for BUILD_BUG and
> > BUILD_BUG_ON).
> >
> > Signed-off-by: Daniel Santos <daniel.santos@...ox.com>
> > ---
> > include/linux/bug.h | 17 +++--------------
> > 1 files changed, 3 insertions(+), 14 deletions(-)
> >
> > diff --git a/include/linux/bug.h b/include/linux/bug.h
> > index 3bc1ddf..b58ba51 100644
> > --- a/include/linux/bug.h
> > +++ b/include/linux/bug.h
> > @@ -81,14 +81,8 @@ struct pt_regs;
> > #ifndef __OPTIMIZE__
> > #define BUILD_BUG_ON(condition) __compiletime_error_fallback(condition)
> > #else
> > -#define BUILD_BUG_ON(condition) \
> > - do { \
> > - extern void __build_bug_on_failed(void) \
> > - __compiletime_error("BUILD_BUG_ON failed"); \
> > - __compiletime_error_fallback(condition); \
> > - if (condition) \
> > - __build_bug_on_failed(); \
> > - } while(0)
> > +#define BUILD_BUG_ON(condition) \
> > + BUILD_BUG_ON_MSG(condition, "BUILD_BUG_ON failed: " #condition)
>
> Concatenating "condition" might not be very informative in all cases.
> For example:
>
> BUILD_BUG_ON(1);
>
> Having __LINE__ is good enough IMHO.
While it doesn't always help, it may help sometimes. Worst case,
BUILD_BUG_ON(1) gives you no less information than it did before; best
case, it gives you useful data.
- Josh Triplett
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists