lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Tue, 15 Jan 2013 11:10:53 -0700
From:	Stephen Warren <swarren@...dotorg.org>
To:	Linus Walleij <linus.walleij@...ricsson.com>
CC:	linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
	Stephen Warren <swarren@...dia.com>,
	Anmar Oueja <anmar.oueja@...aro.org>,
	Lee Jones <lee.jones@...aro.org>,
	Patrice Chotard <patrice.chotard@...com>,
	Linus Walleij <linus.walleij@...aro.org>
Subject: Re: [PATCH 4/4] pinctrl/abx500: add AB8500 pinctrl driver

On 01/15/2013 02:43 AM, Linus Walleij wrote:
> From: Patrice Chotard <patrice.chotard@...com>
> 
> This adds a subdriver for the AB8500 pinctrl portions.

> diff --git a/drivers/pinctrl/pinctrl-ab8500.c b/drivers/pinctrl/pinctrl-ab8500.c

> +static struct abx500_pinctrl_soc_data ab8500_ranges_soc = {
> +	.gpio_ranges = ab8500_pinranges,
> +	.gpio_num_ranges = ARRAY_SIZE(ab8500_pinranges),
> +	.pins = ab8500_ranges_pins,
> +	.npins = ARRAY_SIZE(ab8500_ranges_pins),
> +	.functions = ab8500_ranges_functions,
> +	.nfunctions = ARRAY_SIZE(ab8500_ranges_functions),
> +	.groups = ab8500_ranges_groups,
> +	.ngroups = ARRAY_SIZE(ab8500_ranges_groups),
> +	.alternate_functions = ab8500_alternate_functions,
> +	.gpio_irq_cluster = ab8500_gpio_irq_cluster,
> +	.ngpio_irq_cluster = ARRAY_SIZE(ab8500_gpio_irq_cluster),
> +	.irq_gpio_rising_offset = AB8500_INT_GPIO6R,
> +	.irq_gpio_falling_offset = AB8500_INT_GPIO6F,
> +	.irq_gpio_factor = 1,
> +};
> +
> +void __devinit
> +abx500_pinctrl_ab8500_init(struct abx500_pinctrl_soc_data **soc)
> +{
> +	*soc = &ab8500_ranges_soc;
> +}

"ranges" in that variable name seems a little odd since it's much more
than ranges... But otherwise, this patch, very briefly,

Reviewed-by: Stephen Warren <swarren@...dia.com>


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ