[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <50F5FD7E.4080901@linux.vnet.ibm.com>
Date: Tue, 15 Jan 2013 17:08:14 -0800
From: Dave Hansen <dave@...ux.vnet.ibm.com>
To: Cody P Schafer <cody@...ux.vnet.ibm.com>
CC: Linux MM <linux-mm@...ck.org>, LKML <linux-kernel@...r.kernel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Catalin Marinas <catalin.marinas@....com>
Subject: Re: [PATCH 01/17] mm/compaction: rename var zone_end_pfn to avoid
conflicts with new function
On 01/15/2013 04:24 PM, Cody P Schafer wrote:
> Patches that follow add a inline function zone_end_pfn(), which
> conflicts with the naming of a local variable in isolate_freepages().
>
> Rename the variable so it does not conflict.
It's probably worth a note here that you _will_ be migrating this use
over to the new function anyway.
> @@ -706,7 +706,7 @@ static void isolate_freepages(struct zone *zone,
> * only scans within a pageblock
> */
> end_pfn = ALIGN(pfn + 1, pageblock_nr_pages);
> - end_pfn = min(end_pfn, zone_end_pfn);
> + end_pfn = min(end_pfn, z_end_pfn);
Is there any reason not to just completely get rid of z_end_pfn (in the
later patches after you introduce zone_end_pfn() of course):
> + end_pfn = min(end_pfn, zone_end_pfn(zone));
I wouldn't be completely opposed to you just introducing zone_end_pfn()
and doing all the replacements in a single patch. It would make it
somewhat easier to review, and it would also save the juggling you have
to do with this one.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists