[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <50F6000A.3010601@linux.vnet.ibm.com>
Date: Tue, 15 Jan 2013 17:19:06 -0800
From: Dave Hansen <dave@...ux.vnet.ibm.com>
To: Cody P Schafer <cody@...ux.vnet.ibm.com>
CC: Linux MM <linux-mm@...ck.org>, LKML <linux-kernel@...r.kernel.org>,
Andrew Morton <akpm@...ux-foundation.org>,
Catalin Marinas <catalin.marinas@....com>,
Cody P Schafer <jmesmon@...il.com>
Subject: Re: [PATCH 02/17] mmzone: add various zone_*() helper functions.
On 01/15/2013 04:24 PM, Cody P Schafer wrote:
> +static inline bool zone_spans_pfn(const struct zone *zone, unsigned long pfn)
> +{
> + return zone->zone_start_pfn <= pfn && pfn < zone_end_pfn(zone);
> +}
This needs some parenthesis, just for readability. There's also no
crime in breaking it up to be multi-line if you want.
> +static inline bool zone_is_initialized(struct zone *zone)
> +{
> + return !!zone->wait_table;
> +}
> +
> +static inline bool zone_is_empty(struct zone *zone)
> +{
> + return zone->spanned_pages == 0;
> +}
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists