[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20130205172057.3be4dbd4.akpm@linux-foundation.org>
Date: Tue, 5 Feb 2013 17:20:56 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: Zhang Yanfei <zhangyanfei@...fujitsu.com>
Cc: Johannes Weiner <hannes@...xchg.org>,
Zhang Yanfei <zhangyanfei.yes@...il.com>,
Linux MM <linux-mm@...ck.org>, mgorman@...e.de,
minchan@...nel.org, kamezawa.hiroyu@...fujitsu.com,
m.szyprowski@...sung.com, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 0/3] mm: rename confusing function names
On Wed, 06 Feb 2013 09:06:05 +0800
Zhang Yanfei <zhangyanfei@...fujitsu.com> wrote:
> So could I rename the functions to the names like
> nr_available_buffer_high_pages
> And accurately document them with code comments just as you suggested.
gee. "available" implies "available for you to allocate". It has the
same problem as "free".
And "buffer" shouldn't be there - that's a reflection of the fact
that buffer_head payloads are not allocated from highmem. An archaic
irrelevant thing.
Seriously, first let's write down the descriptions of what these
functions *do*. Then choose nice names which abbreviate that.
hm,
static unsigned int nr_free_zone_pages(int offset)
{
...
unsigned int sum = 0;
...
return sum;
}
How long will it be until these things start exploding from
sums-of-zones which exceed 16TB?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists