[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20130212182355.GA5642@redhat.com>
Date: Tue, 12 Feb 2013 20:23:55 +0200
From: "Michael S. Tsirkin" <mst@...hat.com>
To: Paolo Bonzini <pbonzini@...hat.com>
Cc: linux-kernel@...r.kernel.org,
Wanlong Gao <gaowanlong@...fujitsu.com>, asias@...hat.com,
Rusty Russell <rusty@...tcorp.com.au>, kvm@...r.kernel.org,
virtualization@...ts.linux-foundation.org
Subject: Re: [PATCH 1/9] virtio: add functions for piecewise addition of
buffers
On Tue, Feb 12, 2013 at 07:04:27PM +0100, Paolo Bonzini wrote:
> >> Perhaps, but 3 or 4 arguments (in/out/nsg or in/out/nsg_in/nsg_out) just
> >> for this are definitely too many and make the API harder to use.
> >>
> >> You have to find a balance. Having actually used the API, the
> >> possibility of mixing in/out buffers by mistake never even occurred to
> >> me, much less happened in practice, so I didn't consider it a problem.
> >> Mixing in/out buffers in a single call wasn't a necessity, either.
> >
> > It is useful for virtqueue_add_buf implementation.
>
> ret = virtqueue_start_buf(vq, data, out + in, !!out + !!in,
> gfp);
> if (ret < 0)
> return ret;
>
> if (out)
> virtqueue_add_sg(vq, sg, out, DMA_TO_DEVICE);
> if (in)
> virtqueue_add_sg(vq, sg + out, in, DMA_FROM_DEVICE);
>
> virtqueue_end_buf(vq);
> return 0;
>
> How can it be simpler and easier to understand than that?
Like this:
ret = virtqueue_start_buf(vq, data, in, out, gfp);
if (ret < 0)
return ret;
virtqueue_add_sg(vq, sg, in, out);
virtqueue_end_buf(vq);
> > Basically the more consistent the interface is with virtqueue_add_buf,
> > the better.
>
> The interface is consistent with virtqueue_add_buf_single, where out/in
> clearly doesn't make sense.
Hmm, we could make virtqueue_add_buf_single consistent by giving it 'bool in'.
> virtqueue_add_buf and virtqueue_add_sg are very different, despite the
> similar name.
True. The similarity is between _start and _add_buf.
And this is confusing too. Maybe this means
_start and _add_sg should be renamed.
> > I'm not against changing virtqueue_add_buf if you like but let's keep
> > it all consistent.
>
> How can you change virtqueue_add_buf?
Donnu.
--
MST
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists