lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 27 Feb 2013 17:06:18 -0700
From:	Shuah Khan <shuah.khan@...com>
To:	Joerg Roedel <joro@...tes.org>, bhelgaas@...gle.com
Cc:	jiang.liu@...wei.com, shemminger@...tta.com,
	paulmck@...ux.vnet.ibm.com, linasvepstas@...il.com,
	dhowells@...hat.com, davej@...hat.com, tglx@...utronix.de,
	mtk.manpages@...il.com, iommu@...ts.linux-foundation.org,
	linux-pci@...r.kernel.org, wangyijing@...wei.com,
	LKML <linux-kernel@...r.kernel.org>, shuahkhan@...il.com
Subject: [PATCH v2 0/4] pci: Add PCI_BUS() and PCI_DEVID() interfaces to
 return bus number and device id

pci defines PCI_DEVFN(), PCI_SLOT(), and PCI_FUNC() interfaces, however,
it doesn't have interfaces to return PCI bus and PCI device id. Drivers
(AMD IOMMU, and AER) have module specific definitions for PCI_BUS() and
AMD_IOMMU driver also has a module specific interface to calculate PCI
device id from bus number and devfn.

This patch set adds PCI_BUS_NUM(), and PCI_DEVID() to pci.h, changes AER
to use PCI_BUS_NUM() from pci and remove local PCI_BUS() define. Changes
AMD_IOMMU driver to use PCI_BUS_NUM() and PCI_DEVID() from pci and remove
local PCI_BUS() define and local PCI_DEVID() implementation.

Files changed:

[PATCH v2 1/4] pci: Add PCI_BUS_NUM() and PCI_DEVID() interfaces to return bus
           number and device id

 include/linux/pci.h |   15 +++++++++++++++
 1 file changed, 15 insertions(+)

[PATCH v2 2/4] pci/aer: Remove local PCI_BUS() define and use PCI_BUS_NUM()
           from pci

 drivers/pci/pcie/aer/aerdrv_core.c |    4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

[PATCH v2 3/4] iommu/amd: Remove local PCI_BUS() define and use PCI_BUS_NUM()
           from pci

 drivers/iommu/amd_iommu.c       |   12 ++++++------
 drivers/iommu/amd_iommu_init.c  |   34 +++++++++++++++++-----------------
 drivers/iommu/amd_iommu_types.h |    4 +---
 3 files changed, 24 insertions(+), 26 deletions(-)

[PATCH v2 4/4] iommu/amd: Remove calc_devid() and use PCI_DEVID() from pci
(no change to this patch - but tagging it v2 for clarity)

 drivers/iommu/amd_iommu.c       |    2 +-
 drivers/iommu/amd_iommu_init.c  |    6 +++---
 drivers/iommu/amd_iommu_types.h |    7 -------
 3 files changed, 4 insertions(+), 11 deletions(-)



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ