[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAErSpo6DjjSKCFL6CjmqkOAyc1iU1TG1=n=K=AXPcU_r6ZdPGA@mail.gmail.com>
Date: Tue, 26 Mar 2013 15:41:07 -0600
From: Bjorn Helgaas <bhelgaas@...gle.com>
To: shuah.khan@...com
Cc: Joerg Roedel <joro@...tes.org>, Jiang Liu <jiang.liu@...wei.com>,
"shemminger@...tta.com" <shemminger@...tta.com>,
Paul McKenney <paulmck@...ux.vnet.ibm.com>,
Linas Vepstas <linasvepstas@...il.com>,
David Howells <dhowells@...hat.com>,
Dave Jones <davej@...hat.com>,
Thomas Gleixner <tglx@...utronix.de>,
Michael Kerrisk-manpages <mtk.manpages@...il.com>,
iommu@...ts.linux-foundation.org,
"linux-pci@...r.kernel.org" <linux-pci@...r.kernel.org>,
Yijing Wang <wangyijing@...wei.com>,
LKML <linux-kernel@...r.kernel.org>,
Shuah Khan <shuahkhan@...il.com>
Subject: Re: [PATCH v2 0/4] pci: Add PCI_BUS() and PCI_DEVID() interfaces to
return bus number and device id
On Wed, Feb 27, 2013 at 5:06 PM, Shuah Khan <shuah.khan@...com> wrote:
> pci defines PCI_DEVFN(), PCI_SLOT(), and PCI_FUNC() interfaces, however,
> it doesn't have interfaces to return PCI bus and PCI device id. Drivers
> (AMD IOMMU, and AER) have module specific definitions for PCI_BUS() and
> AMD_IOMMU driver also has a module specific interface to calculate PCI
> device id from bus number and devfn.
>
> This patch set adds PCI_BUS_NUM(), and PCI_DEVID() to pci.h, changes AER
> to use PCI_BUS_NUM() from pci and remove local PCI_BUS() define. Changes
> AMD_IOMMU driver to use PCI_BUS_NUM() and PCI_DEVID() from pci and remove
> local PCI_BUS() define and local PCI_DEVID() implementation.
>
> Files changed:
>
> [PATCH v2 1/4] pci: Add PCI_BUS_NUM() and PCI_DEVID() interfaces to return bus
> number and device id
>
> include/linux/pci.h | 15 +++++++++++++++
> 1 file changed, 15 insertions(+)
>
> [PATCH v2 2/4] pci/aer: Remove local PCI_BUS() define and use PCI_BUS_NUM()
> from pci
>
> drivers/pci/pcie/aer/aerdrv_core.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> [PATCH v2 3/4] iommu/amd: Remove local PCI_BUS() define and use PCI_BUS_NUM()
> from pci
>
> drivers/iommu/amd_iommu.c | 12 ++++++------
> drivers/iommu/amd_iommu_init.c | 34 +++++++++++++++++-----------------
> drivers/iommu/amd_iommu_types.h | 4 +---
> 3 files changed, 24 insertions(+), 26 deletions(-)
>
> [PATCH v2 4/4] iommu/amd: Remove calc_devid() and use PCI_DEVID() from pci
> (no change to this patch - but tagging it v2 for clarity)
>
> drivers/iommu/amd_iommu.c | 2 +-
> drivers/iommu/amd_iommu_init.c | 6 +++---
> drivers/iommu/amd_iommu_types.h | 7 -------
> 3 files changed, 4 insertions(+), 11 deletions(-)
Thanks, Shuah, I applied these to a pci/shuah-defines branch and pushed it.
Since some of these touch drivers/iommu, it'd be good if you acked
them again, Joerg. I know you acked them before, but there have been
minor changes since then, so I didn't add your ack to these. But if
you're still OK with them, I'll refresh the branch to add it now.
Bjorn
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists