[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1372178420.1245.59.camel@joe-AO722>
Date: Tue, 25 Jun 2013 09:40:20 -0700
From: Joe Perches <joe@...ches.com>
To: Rupesh Gujare <rupesh.gujare@...el.com>
Cc: devel@...uxdriverproject.org, linux-usb@...r.kernel.org,
linux-kernel@...r.kernel.org, gregkh@...uxfoundation.org,
shigekatsu.tateno@...el.com
Subject: Re: [PATCH] staging: ozwpan: Convert printk to dev_dbg()
On Tue, 2013-06-25 at 17:30 +0100, Rupesh Gujare wrote:
> convert all debug messages from printk to dev_dbg() & add kernel config to
> enable/disable these messages during compilation.
[]
> -#define oz_trace(...) printk(TRACE_PREFIX __VA_ARGS__)
> +#define oz_trace(fmt, ...) dev_dbg(g_oz_wpan_dev, fmt, ##__VA_ARGS__);
> #ifdef WANT_VERBOSE_TRACE
> extern unsigned long trace_flags;
> -#define oz_trace2(_flag, ...) \
> - do { if (trace_flags & _flag) printk(TRACE_PREFIX __VA_ARGS__); \
> +#define oz_trace2(_flag, fmt, ...) \
> + do { if (trace_flags & _flag) \
> + dev_dbg(g_oz_wpan_dev, fmt, ##__VA_ARGS__); \
> } while (0)
I think oz_trace is a poor name.
It implies you're using the trace subsystem
trace_flags as a global name is also poor
g_oz_wpan_dev is too as it limits the module to
a single dev instance.
I suggest:
#define oz_dbg(level, fmt, ...) \
do { \
if (level & oz_dbg_mask) \
dev_dbg(g_oz_wpan_dev, fmt, ##__VA_ARGS__); \
} while (0)
or better avoiding the single dev:
#define oz_dbg(level, dev, fmt, ...) \
do { \
if (level & oz_dbg_mask) \
dev_dbg(dev, fmt, ##__VA_ARGS__); \
} while (0)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists