lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 04 Sep 2013 16:08:52 +0900
From:	Namhyung Kim <namhyung@...nel.org>
To:	Masami Hiramatsu <masami.hiramatsu.pt@...achi.com>
Cc:	Steven Rostedt <rostedt@...dmis.org>,
	Namhyung Kim <namhyung.kim@....com>,
	Hyeoncheol Lee <cheol.lee@....com>,
	LKML <linux-kernel@...r.kernel.org>,
	Srikar Dronamraju <srikar@...ux.vnet.ibm.com>,
	Oleg Nesterov <oleg@...hat.com>,
	"zhangwei\(Jovi\)" <jovi.zhangwei@...wei.com>,
	Arnaldo Carvalho de Melo <acme@...stprotocols.net>
Subject: Re: [PATCH 10/13] tracing/uprobes: Fetch args before reserving a ring buffer

On Tue, 03 Sep 2013 19:50:28 +0900, Masami Hiramatsu wrote:
> (2013/09/03 14:44), Namhyung Kim wrote:
>> From: Namhyung Kim <namhyung.kim@....com>
>> 
>> Fetching from user space should be done in a non-atomic context.  So
>> use a per-cpu buffer and copy its content to the ring buffer
>> atomically.  Note that we can migrate during accessing user memory
>> thus use a per-cpu mutex to protect concurrent accesses.
>> 
>> This is needed since we'll be able to fetch args from an user memory
>> which can be swapped out.  Before that uprobes could fetch args from
>> registers only which saved in a kernel space.
>> 
>> While at it, use __get_data_size() and store_trace_args() to reduce
>> code duplication.

[SNIP]

>> +	size = esize + tu->p.size + dsize;
>>  	event = trace_current_buffer_lock_reserve(&buffer, call->event.type,
>> -						  size + tu->p.size, 0, 0);
>> -	if (!event)
>> +						  size, 0, 0);
>> +	if (!event) {
>> +		mutex_unlock(mutex);
>>  		return;
>
> Just for a maintenance reason, I personally like to use "goto" in this case
> to fold up the mutex_unlock. :)
>
> Other parts are good for me.
>
> Reviewed-by: Masami Hiramatsu <masami.hiramatsu.pt@...achi.com>

Thank you for review!

I'll change it as you said and fix atomic_dec bug that Jovi found.

Thanks,
Namhyung
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ