lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <528E83B6.5040107@intel.com>
Date:	Thu, 21 Nov 2013 14:05:42 -0800
From:	Dave Hansen <dave.hansen@...el.com>
To:	Luiz Capitulino <lcapitulino@...hat.com>,
	linux-kernel@...r.kernel.org
CC:	linux-mm@...ck.org, akpm@...ux-foundation.org
Subject: Re: [PATCH] mm/bootmem.c: remove unused 'limit' variable

On 11/21/2013 01:43 PM, Luiz Capitulino wrote:
> @@ -655,9 +655,7 @@ restart:
>  void * __init __alloc_bootmem_nopanic(unsigned long size, unsigned long align,
>  					unsigned long goal)
>  {
> -	unsigned long limit = 0;
> -
> -	return ___alloc_bootmem_nopanic(size, align, goal, limit);
> +	return ___alloc_bootmem_nopanic(size, align, goal, 0);
>  }

FWIW, I like those.  The way you leave it:

	return ___alloc_bootmem_nopanic(size, align, goal, 0);

the 0 is a magic number that you have to go look up the declaration of
___alloc_bootmem_nopanic() to decipher, or you have to add a comment to
it in some way.

I find it much more readable to have an 'unused' variable like that.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ