[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20131202145105.c8027647503eece9a099462f@linux-foundation.org>
Date: Mon, 2 Dec 2013 14:51:05 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: Naoya Horiguchi <n-horiguchi@...jp.nec.com>
Cc: Joonsoo Kim <iamjoonsoo.kim@....com>, Mel Gorman <mgorman@...e.de>,
Hugh Dickins <hughd@...gle.com>,
Rik van Riel <riel@...hat.com>,
Ingo Molnar <mingo@...nel.org>,
Hillf Danton <dhillf@...il.com>, linux-kernel@...r.kernel.org,
linux-mm@...ck.org, Joonsoo Kim <js1304@...il.com>
Subject: Re: [PATCH 4/9] mm/rmap: make rmap_walk to get the
rmap_walk_control argument
On Mon, 02 Dec 2013 15:09:33 -0500 Naoya Horiguchi <n-horiguchi@...jp.nec.com> wrote:
> > --- a/include/linux/rmap.h
> > +++ b/include/linux/rmap.h
> > @@ -235,11 +235,16 @@ struct anon_vma *page_lock_anon_vma_read(struct page *page);
> > void page_unlock_anon_vma_read(struct anon_vma *anon_vma);
> > int page_mapped_in_vma(struct page *page, struct vm_area_struct *vma);
> >
> > +struct rmap_walk_control {
> > + int (*main)(struct page *, struct vm_area_struct *,
> > + unsigned long, void *);
>
> Maybe you can add parameters' names to make this prototype more readable.
>
Yes, I find it quite maddening when the names are left out. They're really
very useful for understanding what's going on.
The name "main" seems odd as well. What does "main" mean? "rmap_one"
was better, but "rmap_one_page" or "rmap_one_pte" or whatever would
be better.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists