[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20140531122945.GA20736@n2100.arm.linux.org.uk>
Date: Sat, 31 May 2014 13:29:45 +0100
From: Russell King - ARM Linux <linux@....linux.org.uk>
To: srinivas.kandagatla@...aro.org
Cc: Ulf Hansson <ulf.hansson@...aro.org>, linux-mmc@...r.kernel.org,
Chris Ball <chris@...ntf.net>, linux-kernel@...r.kernel.org,
linux-arm-msm@...r.kernel.org, linus.walleij@...aro.org
Subject: Re: [PATCH v5 11/13] mmc: mmci: add explicit clk control
On Fri, May 30, 2014 at 06:14:40PM +0100, srinivas.kandagatla@...aro.org wrote:
> @@ -1325,6 +1329,18 @@ static void mmci_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
> if (!ios->clock && variant->pwrreg_clkgate)
> pwr &= ~MCI_PWR_ON;
>
> + if ((host->variant->explicit_mclk_control) &&
> + (ios->clock != host->clock_cache)) {
Please explain what use these parens have (or just get rid of them as
they're completely unnecessary - they do nothing for readability.)
In fact, additional useless parens result in readability being harmed.
If you don't know the C precedence rules and as a result feel the need
to litter your code with additional parens, then you really shouldn't
be touching C code in the first place. :)
--
FTTC broadband for 0.8mile line: now at 9.7Mbps down 460kbps up... slowly
improving, and getting towards what was expected from it.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists