lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 23 Jul 2014 23:30:44 +0100
From:	Jamie Lentin <jm@...tin.co.uk>
To:	Jiri Kosina <jkosina@...e.cz>, Antonio Ospite <ao2@....it>,
	Hans de Goede <hdegoede@...hat.com>
Cc:	linux-input@...r.kernel.org, linux-kernel@...r.kernel.org,
	Jamie Lentin <jm@...tin.co.uk>
Subject: [PATCH v5 0/4] HID: lenovo: Add support for Lenovo Compact Keyboard

This patchset follows on from my previous attempts to add support for
these keyboards from Lenovo.

Antonio, I've used cptkbd_data and left data_pointer for now. It'd be
an easy patch to change data_pointer to tpkbd_data, but is drifting
away from what this patchset is supposed to do. Could send that
afterwards though.

Changes since v4: https://lkml.org/lkml/2014/7/13/14
* Remember to add prefixes to subjects (whooops) [Antonio Ospite]
* Don't allocate drvdata for non-interesting half of USB
  keyboard [Antonio Ospite]
* Some pointer/trackpoint comment clarifications [Antonio Ospite]
* Change tpcsc -> cptkbd_data [Antonio Ospite]
* Only bother doing sysfs_remove_group if there's a data_pointer
  [Antonio Ospite]

Changes since v3: https://lkml.org/lkml/2014/6/15/159
* Break up first patch [Antonio Ospite]
* Rename ABI docs too [Jiri Kosina]
* Spelling and Grammar, style fixes [Antonio Ospite]
* Driver should just be called 'lenovo' [Antonio Ospite]
* Remove useless id from probe functions [Antonio Ospite]
* Use KEY_SCALE to match Thinkpad ??40 models [Hans de Goede]
* Add ABI documentation for fn_lock setting [Jiri Kosina]
* Use a bool for fn_lock instead of uint [Antonio Ospite]
* hid_output_raw_report has been replaced with hid_hw_raw_request [Antonio Ospite]

Changes since v2: https://lkml.org/lkml/2014/6/10/730
* Rename hid-lenovo-tpkbd to hid-lenovo, to make it obvious this is
  for any Lenovo-manufactured device [Antonio Ospite, Jiri Kosina]
* Style fixes: function calls in conditions, combine checks for 
  both USB & BT keyboards [Antonio Ospite]

Changes since v1: https://lkml.org/lkml/2014/3/25/535
* Merge driver into hid-lenovo-tpkbd.c instead of creating our own
  driver for the hardware [Jiri Kosina]
* Remove key mappings which are now supported by standard
* Use KEY_FILE for Fn-F12 (opens My Computer on Windows)
* Support the USB variant as well as Bluetooth
* Expose the Fn Lock setting as a sysfs attribute instead of trying to
  build a mechanism to toggle into the kernel

Applies against v3.16-rc4, tested with Bluetooth and USB variants of the
Compact Keyboard with Trackpoint.

Cheers,

Jamie Lentin (4):
  HID: lenovo: Rename hid-lenovo-tpkbd to hid-lenovo
  HID: lenovo: Prepare support for adding other devices
  HID: lenovo: Style fixes
  HID: lenovo: Add support for Compact (BT|USB) keyboard

 ...er-hid-lenovo-tpkbd => sysfs-driver-hid-lenovo} |  12 +
 drivers/hid/Kconfig                                |  16 +-
 drivers/hid/Makefile                               |   2 +-
 drivers/hid/hid-core.c                             |   4 +-
 drivers/hid/hid-ids.h                              |   2 +
 drivers/hid/hid-lenovo-tpkbd.c                     | 462 --------------
 drivers/hid/hid-lenovo.c                           | 708 +++++++++++++++++++++
 include/linux/hid.h                                |   1 +
 8 files changed, 736 insertions(+), 471 deletions(-)
 rename Documentation/ABI/testing/{sysfs-driver-hid-lenovo-tpkbd => sysfs-driver-hid-lenovo} (75%)
 delete mode 100644 drivers/hid/hid-lenovo-tpkbd.c
 create mode 100644 drivers/hid/hid-lenovo.c

-- 
2.0.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ