lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 24 Jul 2014 15:19:01 -0600
From:	Stephen Warren <swarren@...dotorg.org>
To:	Nick Dyer <nick.dyer@...ev.co.uk>
CC:	Dmitry Torokhov <dmitry.torokhov@...il.com>,
	Yufeng Shen <miletus@...gle.com>,
	Daniel Kurtz <djkurtz@...omium.org>,
	Henrik Rydberg <rydberg@...omail.se>,
	Joonyoung Shim <jy0922.shim@...sung.com>,
	Alan Bowens <Alan.Bowens@...el.com>,
	linux-input@...r.kernel.org, linux-kernel@...r.kernel.org,
	Peter Meerwald <pmeerw@...erw.net>,
	Benson Leung <bleung@...omium.org>,
	Olof Johansson <olofj@...omium.org>,
	Sekhar Nori <nsekhar@...com>
Subject: Re: [PATCH 00/15] atmel_mxt_ts - device tree, bootloader, etc

On 07/24/2014 07:47 AM, Nick Dyer wrote:
> On 23/07/14 18:22, Stephen Warren wrote:
>> That didn't make any difference.
>>
>> I also tried the tool interactively. the "Display raw (M)essages" option
>> never displayed anything, and the couple of self-tests I tried just
>> timed out. "Read (I)nfo block" did display some values that seemed like
>> they might be correct rather than random data.
>>
>> Interestingly though, I did bisect the series and found "Input:
>> atmel_mxt_ts - use deep sleep mode when stopped" causes the problem. If
>> I apply the whole series and revert that one patch, the touchpad works
>> for mouse movement, but interestingly not for taps or physical clicks.
>
> Could you dump out the config for me (when it's in the failed state)? This
> can be done by running:
>
> mxt-app [device] --save fail.xcfg

That command always experiences a timeout error, but still seems to dump 
something out. Is this timeout error an issue? I'm a little hesitant to 
modify the COMMSCONFIG settings until I know load/save are really working.

root@...alhost:~/obp-utils# ./mxt-app -d i2c-dev:1-004b --save 
~/mxt-save-no-movement.xml
Version:1.16-65-g0a4c
Registered i2c-dev adapter:1 address:0x4b
Opening config file /root/mxt-save-no-movement.xml...
REPORTALL command issued
Timeout

I've uploaded 2 logs to:

http://avon.wwwdotorg.org/downloads/mxt-logs/
(note there's no directory indexing, so manually add the filenames below 
to the URL)

mxt-save-no-movement.xml

This is with the whole series applied. Neither mouse movement nor clicks 
works. I tried mxt-app --reset and it made no difference to the dump 
results.

mxt-save-move-ok-no-clicking.xml

This is with "Input: atmel_mxt_ts - use deep sleep mode when stopped" 
reverted; mouse movement works, but clicking doesn't.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists