lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Thu, 07 Aug 2014 07:59:31 -0600
From:	Shuah Khan <>
To:	Greg KH <>, Michal Marek <>
	" >> Sam Ravnborg" <>
Subject: Re: [PATCH] kbuild: devtest - new make target for build all and run

On 08/06/2014 08:31 AM, Greg KH wrote:
> On Wed, Aug 06, 2014 at 04:06:33PM +0200, Michal Marek wrote:
>> On 2014-08-06 16:04, Shuah Khan wrote:
>>> On 08/06/2014 07:51 AM, Michal Marek wrote:
>>>> On 2014-07-18 22:44, Shuah Khan wrote:
>>>>> Add a new devtest make target to enable developer testing. This
>>>>> new target does full build (make all) and then runs selftests.
>>>> I agree with Sam that the name is rather ambiguous, but I can't suggest
>>>> a better alternative right now.
>>> Does kselftest or kern_selftest sound better?
>> It does sound better to me than dev(ice)test, but I'm not a native
>> English speaker. Greg?
> Either is fine with me, but I don't think we have '_' as any make target
> today, so perhaps "kselftest" is best?
> thanks,
> greg k-h

Patch v2 is on its way. kselftest is the new target. It does sound lot
better than devtest :)

-- Shuah

Shuah Khan
Senior Linux Kernel Developer - Open Source Group
Samsung Research America(Silicon Valley) | (970) 672-0658
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists