[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20140910132933.GG1436@atomlin.usersys.redhat.com>
Date: Wed, 10 Sep 2014 14:29:33 +0100
From: Aaron Tomlin <atomlin@...hat.com>
To: Chuck Ebbert <cebbert.lkml@...il.com>
Cc: peterz@...radead.org, mingo@...hat.com, dzickus@...hat.com,
bmr@...hat.com, jcastillo@...hat.com, oleg@...hat.com,
pzijlstr@...hat.com, riel@...hat.com, prarit@...hat.com,
jgh@...hat.com, linux-kernel@...r.kernel.org, tglx@...utronix.de,
x86@...nel.org, rostedt@...dmis.org, hannes@...xchg.org,
aneesh.kumar@...ux.vnet.ibm.com, akpm@...ux-foundation.org,
akpm@...gle.com, linuxppc-dev@...ts.ozlabs.org, minchan@...nel.org
Subject: Re: [PATCH v2 1/3] init/main.c: Give init_task a canary
On Wed, Sep 10, 2014 at 02:26:54AM -0500, Chuck Ebbert wrote:
> On Tue, 9 Sep 2014 10:42:27 +0100
> Aaron Tomlin <atomlin@...hat.com> wrote:
>
> > +void task_stack_end_magic(struct task_struct *tsk)
> > +{
> > + unsigned long *stackend;
> > +
> > + stackend = end_of_stack(tsk);
> > + *stackend = STACK_END_MAGIC; /* for overflow detection */
> > +}
> > +
>
> For clarity this should probably be called set_task_stack_end_magic().
Agreed.
> And has this been tested on parisc and metag, which use STACK_GROWSUP ?
> I can't see how end_of_stack() as it's defined now could work on those archs.
AFAIU, dup_task_struct() has always done this explicitly.
I see no reason why init_task requires special attention.
--
Aaron Tomlin
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists