[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5418FDEC.40201@martingkelly.com>
Date: Tue, 16 Sep 2014 20:20:12 -0700
From: Martin Kelly <martin@...tingkelly.com>
To: "Li, Aubrey" <aubrey.li@...ux.intel.com>, x86@...nel.org,
mingo@...hat.com
CC: vishwesh.m.rudramuni@...el.com, joe@...ches.com,
hpa@...ux.intel.com, linux-kernel@...r.kernel.org,
Martin Kelly <martkell@...zon.com>
Subject: Re: [PATCH v2] x86/pmc_atom: Fix warning when CONFIG_DEBUG_FS=n
On 09/16/2014 07:09 PM, Li, Aubrey wrote:
>
> Thanks to take care of this warning. How about this version?
>
> diff --git a/arch/x86/kernel/pmc_atom.c b/arch/x86/kernel/pmc_atom.c
> index 0c424a6..cd91b57 100644
> --- a/arch/x86/kernel/pmc_atom.c
> +++ b/arch/x86/kernel/pmc_atom.c
> @@ -240,7 +240,7 @@ err:
> static int pmc_setup_dev(struct pci_dev *pdev)
> {
> struct pmc_dev *pmc = &pmc_device;
> - int ret;
> + int ret = 0;
>
> /* Obtain ACPI base address */
> pci_read_config_dword(pdev, ACPI_BASE_ADDR_OFFSET, &acpi_base_addr);
> @@ -269,7 +269,7 @@ static int pmc_setup_dev(struct pci_dev *pdev)
> return ret;
> }
> #endif /* CONFIG_DEBUG_FS */
> - return 0;
> + return ret;
> }
>
> /*
>
> Thanks,
> -Aubrey
>
Thanks for the suggestion, Aubrey. Although that version would also work, it still has inline #ifdef, which is harder to read and goes against general Linux conventions:
https://www.kernel.org/doc/Documentation/SubmittingPatches
(section 2, "#ifdefs are ugly")
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists