lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 17 Sep 2014 11:44:41 +0800
From:	"Li, Aubrey" <aubrey.li@...ux.intel.com>
To:	Martin Kelly <martin@...tingkelly.com>, x86@...nel.org,
	mingo@...hat.com
CC:	vishwesh.m.rudramuni@...el.com, joe@...ches.com,
	hpa@...ux.intel.com, linux-kernel@...r.kernel.org,
	Martin Kelly <martkell@...zon.com>
Subject: Re: [PATCH v2] x86/pmc_atom: Fix warning when CONFIG_DEBUG_FS=n

On 2014/9/17 11:20, Martin Kelly wrote:
> On 09/16/2014 07:09 PM, Li, Aubrey wrote:
>>
>> Thanks to take care of this warning. How about this version?
>>
>> diff --git a/arch/x86/kernel/pmc_atom.c b/arch/x86/kernel/pmc_atom.c
>> index 0c424a6..cd91b57 100644
>> --- a/arch/x86/kernel/pmc_atom.c
>> +++ b/arch/x86/kernel/pmc_atom.c
>> @@ -240,7 +240,7 @@ err:
>>  static int pmc_setup_dev(struct pci_dev *pdev)
>>  {
>>  	struct pmc_dev *pmc = &pmc_device;
>> -	int ret;
>> +	int ret = 0;
>>  
>>  	/* Obtain ACPI base address */
>>  	pci_read_config_dword(pdev, ACPI_BASE_ADDR_OFFSET, &acpi_base_addr);
>> @@ -269,7 +269,7 @@ static int pmc_setup_dev(struct pci_dev *pdev)
>>  		return ret;
>>  	}
>>  #endif /* CONFIG_DEBUG_FS */
>> -	return 0;
>> +	return ret;
>>  }
>>  
>>  /*
>>
>> Thanks,
>> -Aubrey
>>
> 
> Thanks for the suggestion, Aubrey. Although that version would also work, it still has inline #ifdef, which is harder to read and goes against general Linux conventions:

Why do you want to call pmc_dbgfs_register() anyway even if
CONFIG_DEBUG_FS=n?

Thanks,
-Aubrey

> 
> https://www.kernel.org/doc/Documentation/SubmittingPatches
> (section 2, "#ifdefs are ugly")
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
> 
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ