[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20141215115956.GD4856@mwanda>
Date: Mon, 15 Dec 2014 14:59:56 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: One Thousand Gnomes <gnomes@...rguk.ukuu.org.uk>
Cc: Jeremiah Mahler <jmmahler@...il.com>, devel@...verdev.osuosl.org,
gregkh@...uxfoundation.org, jun.j.tian@...el.com,
linux-kernel@...r.kernel.org, joe@...ches.com,
octavian.purdila@...el.com, apw@...onical.com, nnk@...gle.com,
alan@...ux.intel.com
Subject: Re: [PATCH] checkpatch giving bogus advice (was staging: goldfish:
Fix minor coding style)
I haven't seen any bugs caused by lack of type safety with "!foo"...
I prefer !foo because it is more common in the kernel and I think it's
easier to read but I don't feel strongly about this.
I kind of hate "if (foo != NULL) though, because it's a double negative.
But I really hate when people start adding the "!= 0" on to all their
conditions.
if (frob() != 0)
Also:
if (a + b != 0)
People do this all the time instead of "if (a || b)" and I don't know
why...
regards,
dan carpenter
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists