lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 24 Dec 2014 08:02:30 -0600
From:	Alex Elder <>
To:	Joe Perches <>,
	Masahiro Yamada <>
	Andrew Morton <>,
	Eric Miao <>,
	Haojian Zhuang <>,
	Russell King <>,
	Daniel Mack <>,
	Robert Jarzmik <>,
	Linus Walleij <>,
	Steven Rostedt <>,
	Rusty Russell <>,
	Michal Nazarewicz <>,
	Ingo Molnar <>,
	Peter Zijlstra <>,
	Daniel Borkmann <>,
	Alex Elder <>,
	Daniel Walter <>,
	Peter Hurley <>,,
Subject: Re: [PATCH] linux/kernel.h: merge ARRAY_AND_SIZE defines

On 12/23/2014 11:44 PM, Joe Perches wrote:
> On Wed, 2014-12-24 at 14:38 +0900, Masahiro Yamada wrote:
>> ARRAY_AND_SIZE is a useful macro.  Its definition is already
>> duplicated in some headers.  Move it to include/linux/kernel.h.
> I think it's not a good/useful macro and
> would prefer the uses expanded instead.

For what it's worth, I agree.	-Alex

> The uses of ARRAY_AND_SIZE in structure
> definitions aren't particularly bad, but the
> ARRAY_AND_SIZE uses that hide the number of
> arguments in a function I think are suboptimal.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists