lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Mon, 05 Jan 2015 10:08:22 +1030
From:	Rusty Russell <>
To:	Alex Elder <>, Joe Perches <>,
	Masahiro Yamada <>
	Andrew Morton <>,
	Eric Miao <>,
	Haojian Zhuang <>,
	Russell King <>,
	Daniel Mack <>,
	Robert Jarzmik <>,
	Linus Walleij <>,
	Steven Rostedt <>,
	Michal Nazarewicz <>,
	Ingo Molnar <>,
	Peter Zijlstra <>,
	Daniel Borkmann <>,
	Alex Elder <>,
	Daniel Walter <>,
	Peter Hurley <>,,
Subject: Re: [PATCH] linux/kernel.h: merge ARRAY_AND_SIZE defines

Alex Elder <> writes:
> On 12/23/2014 11:44 PM, Joe Perches wrote:
>> On Wed, 2014-12-24 at 14:38 +0900, Masahiro Yamada wrote:
>>> ARRAY_AND_SIZE is a useful macro.  Its definition is already
>>> duplicated in some headers.  Move it to include/linux/kernel.h.
>> I think it's not a good/useful macro and
>> would prefer the uses expanded instead.
> For what it's worth, I agree.	-Alex

Me too.  It's fine in current usage, but I wouldn't want to see
more of it.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists