[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <552EDE9D.4000601@gmail.com>
Date: Wed, 15 Apr 2015 23:56:45 +0200
From: Mateusz Kulikowski <mateusz.kulikowski@...il.com>
To: Dan Carpenter <dan.carpenter@...cle.com>
CC: gregkh@...uxfoundation.org, devel@...verdev.osuosl.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 15/21] staging: rtl8192e: Fix LONG_LINE warnings -
modify variables
On 14.04.2015 10:40, Dan Carpenter wrote:
> On Mon, Apr 13, 2015 at 11:47:38PM +0200, Mateusz Kulikowski wrote:
>> + if (*rfa_pti_r > 4) {
>> + (*rfa_pti_r)--;
>
>
> Honestly, I thought that patch 14 was too hard to review and did too
> many things, but this one is kind of ridiculous.
>
> - p->rfa_txpowertrackingindex--;
> + (*rfa_pti)--;
>
> The new version is fewer characters but it's way more complicated to
> think about. Just rename rfa_txpowertrackingindex to something
> reasonable. It's a stupid name, because it_hasninegazillionwordsinit
> and it's too long.
>
> "rfa_pti_r" is a terrible name as well. it_also_hngwit_for_realz.
True, but it's also used as local variable in one-screen function;
Nevertheless - I got the point.
> I'm not going to review the rest of this patch.
Thanks for the patience, I will try to split such commits more in future.
As for v3 I assume patches 15, 19, 20 should be reworked; I will:
- Try to find better names for structure members where possible (this mostly
applies to r8192_priv members),
- Do exactly one type of cleanup 'operation' in each commit (this means fixing
one LONG_LINE warning may take more than one commit)
- Avoid playing with pointers like above
- Standardize local variable names in all functions (i.e. if I use igain as
init_gain pointer, I'll do it like that everywhere)
Is it enough or did I missed something?
Regards,
Mateusz
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists