lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 20 Apr 2015 10:51:58 -0500
From:	Tom Tucker <tom@...ngridcomputing.com>
To:	Michael Wang <yun.wang@...fitbricks.com>,
	Steve Wise <swise@...ngridcomputing.com>,
	Roland Dreier <roland@...nel.org>,
	Sean Hefty <sean.hefty@...el.com>, linux-rdma@...r.kernel.org,
	linux-kernel@...r.kernel.org, hal@....mellanox.co.il
CC:	Hoang-Nam Nguyen <hnguyen@...ibm.com>,
	Christoph Raisch <raisch@...ibm.com>,
	Mike Marciniszyn <infinipath@...el.com>,
	Eli Cohen <eli@...lanox.com>,
	Faisal Latif <faisal.latif@...el.com>,
	Jack Morgenstein <jackm@....mellanox.co.il>,
	Or Gerlitz <ogerlitz@...lanox.com>,
	Haggai Eran <haggaie@...lanox.com>,
	Ira Weiny <ira.weiny@...el.com>, Tom Talpey <tom@...pey.com>,
	Jason Gunthorpe <jgunthorpe@...idianresearch.com>,
	Doug Ledford <dledford@...hat.com>
Subject: Re: [PATCH v5 19/27] IB/Verbs: Use management helper cap_iw_cm()

On 4/20/15 10:16 AM, Michael Wang wrote:
> On 04/20/2015 04:00 PM, Steve Wise wrote:
>> On 4/20/2015 3:40 AM, Michael Wang wrote:
> [snip]
>>> diff --git a/include/rdma/ib_verbs.h b/include/rdma/ib_verbs.h
>>> index 6805e3e..e4999f6 100644
>>> --- a/include/rdma/ib_verbs.h
>>> +++ b/include/rdma/ib_verbs.h
>>> @@ -1818,6 +1818,21 @@ static inline int cap_ib_cm(struct ib_device *device, u8 port_num)
>>>        return rdma_ib_or_iboe(device, port_num);
>>>    }
>>>    +/**
>>> + * cap_iw_cm - Check if the port of device has the capability IWARP
>>> + * Communication Manager.
>>> + *
>>> + * @device: Device to be checked
>>> + * @port_num: Port number of the device
>>> + *
>>> + * Return 0 when port of the device don't support IWARP
>>> + * Communication Manager.
>>> + */
>>> +static inline int cap_iw_cm(struct ib_device *device, u8 port_num)
>>> +{
>>> +    return rdma_tech_iwarp(device, port_num);
>>> +}
>>> +
>>>    int ib_query_gid(struct ib_device *device,
>>>             u8 port_num, int index, union ib_gid *gid);
>>>    
>> iWARP devices _must_ support the IWCM so cap_iw_cm() is not really useful.
> Sean suggested to add this helper paired with cap_ib_cm(), may be there are
> some consideration on maintainability?
>
> Me too also prefer this way to make the code more readable ;-)

It's more consistent, but not necessarily more readable -- if by 
readability we mean understanding.

If the reader knows how the transports work, then the reader would be 
confused by the addition of a check that is always true. For the reader 
that doesn't know, the addition of the check implies that the support is 
optional, which it is not.

Tom

> Regards,
> Michael Wang
>
>>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists