[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1436218475.2658.14.camel@freescale.com>
Date: Mon, 6 Jul 2015 16:34:35 -0500
From: Scott Wood <scottwood@...escale.com>
To: wenwei tao <wenweitaowenwei@...il.com>
CC: Izik Eidus <izik.eidus@...ellosystems.com>, <aarcange@...hat.com>,
<chrisw@...s-sol.org>, Hugh Dickins <hughd@...gle.com>,
<tglx@...utronix.de>, <mingo@...hat.com>, <hpa@...or.com>,
<x86@...nel.org>, <viro@...iv.linux.org.uk>, <linux-mm@...ck.org>,
<linux-fsdevel@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<linuxppc-dev@...ts.ozlabs.org>, <kvm@...r.kernel.org>,
<kvm-ppc@...r.kernel.org>
Subject: Re: [RFC PATCH 6/6] powerpc/kvm: change the condition of
identifying hugetlb vm
On Fri, 2015-07-03 at 16:47 +0800, wenwei tao wrote:
> Hi Scott
>
> Thank you for your comments.
>
> Kernel already has that function: is_vm_hugetlb_page() , but the
> original code didn't use it,
> in order to keep the coding style of the original code, I didn't use it
> either.
>
> For the sentence like: "vma->vm_flags & VM_HUGETLB" , hiding it behind
> 'is_vm_hugetlb_page()' is ok,
> but the sentence like: "vma->vm_flags &
> (VM_LOCKED|VM_HUGETLB|VM_PFNMAP)" appears in the patch 2/6,
> is it better to hide the bit combinations behind the
> is_vm_hugetlb_page() ? In my patch I just replaced it with
> "vma->vm_flags & (VM_LOCKED|VM_PFNMAP) || (vma->vm_flags &
> (VM_HUGETLB|VM_MERGEABLE)) == VM_HUGETLB".
If you're going to do non-obvious things with the flags, it should be done in
one place rather than throughout the code. Why would you do the above and
not "vma->vm_flags & (VM_LOCKED | VM_PFNMAP) || is_vm_hugetlb_page(vma)"?
-Scott
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists