[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20150722115204.GA23235@treble.redhat.com>
Date: Wed, 22 Jul 2015 06:52:04 -0500
From: Josh Poimboeuf <jpoimboe@...hat.com>
To: Ingo Molnar <mingo@...nel.org>
Cc: Andy Lutomirski <luto@...capital.net>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>,
"H. Peter Anvin" <hpa@...or.com>, Michal Marek <mmarek@...e.cz>,
Peter Zijlstra <peterz@...radead.org>,
Andy Lutomirski <luto@...nel.org>,
Borislav Petkov <bp@...en8.de>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Andi Kleen <andi@...stfloor.org>,
Pedro Alves <palves@...hat.com>, X86 ML <x86@...nel.org>,
live-patching@...r.kernel.org,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [RFC PATCH 13/21] x86/asm/crypto: Fix frame pointer usage in
aesni-intel_asm.S
On Mon, Jul 20, 2015 at 01:00:06PM -0500, Josh Poimboeuf wrote:
> On Mon, Jul 20, 2015 at 07:21:24PM +0200, Ingo Molnar wrote:
> > * Josh Poimboeuf <jpoimboe@...hat.com> wrote:
> > Ok, I see how the naming scheme I proposed won't work with all that very well, but
> > I'd still suggest using consistently named patterns.
> >
> > Let me suggest yet another approach. How about open-coding something like this:
> >
> > FUNCTION_START(func)
> >
> > push_bp
> > mov_sp_bp
> >
> > ...
> >
> > pop_bp
> > ret
> >
> > FUNCTION_END(func)
> >
> > This is just two easy things:
> >
> > - a redefine of the FUNCTION_ENTRY and ENDPROC names
> >
> > - the introduction of three quasi-mnemonics: push_bp, mov_sp_bp, pop_bp - which
> > all look very similar to a real frame setup sequence, except that we can easily
> > make them go away in the !CONFIG_FRAME_POINTERS case.
> >
> > The advantage of this approach would be:
> >
> > - it looks pretty 'natural' and very close to how the real disassembly looks
> > like in CONFIG_FRAME_POINTERS=y kernels. So while it's not as compact as some
> > of the other variants, it's close to what the real instruction sequence looks
> > like and that is a positive quality in itself.
> >
> > - it also makes it apparent 'on sight' that it's probably a bug to have
> > unbalanced push/pop sequences in a regular function, to any reasonably alert
> > assembly coder.
> >
> > - if we ever unsupport framepointer kernels in the (far far) future, we can get
> > rid of all lines with those 3 mnemonics and be done with it.
> >
> > - it's finegrained enough so that we can express all the special function/tail
> > variants you listed above.
> >
> > What do you think?
>
> I agree that the edge cases make FUNCTION_ENTRY and FUNCTION_RETURN less
> attractive. Slowly we are circling around to where we started :-)
>
> Personally, I prefer FRAME/ENDFRAME instead of push_bp/mov_sp_bp/pop_bp,
> because it more communicates *what* it's doing rather than how. IMO,
> it's easier to grok with a quick glance.
Ingo, any chance this last paragraph was a convincing argument to
continue to use FRAME/ENDFRAME over push_bp/mov_sp_bp/pop_bp?
(I think this is the last outstanding issue from the reviews, so I'm all
set to send out a new version of the patches once there's agreement on
this issue.)
--
Josh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists