[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <55C1FF54.8060409@oracle.com>
Date: Wed, 05 Aug 2015 08:19:32 -0400
From: Boris Ostrovsky <boris.ostrovsky@...cle.com>
To: Julien Grall <julien.grall@...rix.com>,
xen-devel@...ts.xenproject.org
CC: linux-fbdev@...r.kernel.org, "H. Peter Anvin" <hpa@...or.com>,
Jiri Slaby <jslaby@...e.com>, stefano.stabellini@...citrix.com,
Russell King <linux@....linux.org.uk>,
linux-scsi@...r.kernel.org, x86@...nel.org,
Tomi Valkeinen <tomi.valkeinen@...com>,
linux-input@...r.kernel.org,
Jean-Christophe Plagniol-Villard <plagnioj@...osoft.com>,
ian.campbell@...rix.com,
Konrad Rzeszutek Wilk <konrad.wilk@...cle.com>,
"James E.J. Bottomley" <JBottomley@...n.com>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>,
linux-arm-kernel@...ts.infradead.org,
Juergen Gross <jgross@...e.com>, Wei Liu <wei.liu2@...rix.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Dmitry Torokhov <dmitry.torokhov@...il.com>,
linux-kernel@...r.kernel.org,
David Vrabel <david.vrabel@...rix.com>, netdev@...r.kernel.org,
linuxppc-dev@...ts.ozlabs.org,
Roger Pau Monné <roger.pau@...rix.com>
Subject: Re: [PATCH v2 4/8] xen: Use the correctly the Xen memory terminologies
On 08/05/2015 06:51 AM, Julien Grall wrote:
>
>>> diff --git a/drivers/video/fbdev/xen-fbfront.c
>>> b/drivers/video/fbdev/xen-fbfront.c
>>> index 09dc447..25e3cce 100644
>>> --- a/drivers/video/fbdev/xen-fbfront.c
>>> +++ b/drivers/video/fbdev/xen-fbfront.c
>>> @@ -539,7 +539,7 @@ static int xenfb_remove(struct xenbus_device *dev)
>>> static unsigned long vmalloc_to_mfn(void *address)
>>> {
>>> - return pfn_to_mfn(vmalloc_to_pfn(address));
>>> + return pfn_to_gfn(vmalloc_to_pfn(address));
>>> }
>> Are you sure? This will return vmalloc_to_pfn(address)).
> I guess you mean vmalloc_to_mfn will return vmalloc_to_pfn?
>
> If so, it will be only the case on auto-translated case (because pfn ==
> gfn). In the case of PV, the mfn will be returned.
How will mfn be returned on PV when pfn_to_gfn() is an identity function?
static inline unsigned long pfn_to_gfn(unsigned long pfn)
{
return pfn;
}
-boris
>
> Although, this function is misnamed. It's fixed in a follow-up patch
> (see #6) because it's required more renaming than this function. I
> didn't want to add such changes within this patch.
>
> Regards,
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists