[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20150807154525.GO16853@twins.programming.kicks-ass.net>
Date: Fri, 7 Aug 2015 17:45:25 +0200
From: Peter Zijlstra <peterz@...radead.org>
To: Vineet Gupta <vgupta@...opsys.com>
Cc: Oleg Nesterov <oleg@...hat.com>,
Alexander Viro <viro@...iv.linux.org.uk>,
linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] coredump: Replace opencoded set_mask_bits()
On Fri, Aug 07, 2015 at 09:05:06PM +0530, Vineet Gupta wrote:
> On Friday 07 August 2015 08:27 PM, Peter Zijlstra wrote:
> > On Fri, Aug 07, 2015 at 08:14:03PM +0530, Vineet Gupta wrote:
> >
> >> > See, I have such a cmpxchg loop in ARC code - originally from Peter :-)
> >> > arch/arc/kernel/smp.c. @ipi_data_ptr is NOT atomic_t
> >> >
> >> > do {
> >> > new = old = ACCESS_ONCE(*ipi_data_ptr);
> >> > new |= 1U << msg;
> >> > } while (cmpxchg(ipi_data_ptr, old, new) != old);
> >> >
> > Well, you'll have atomic_or() real soon now.
>
> Doesn't help my cause - ipi_data_ptr is not atomic_t - hence my prev question in
> this thread
A cast will work :-)
But yes, ideally everything will be type safe because of those archs
that cannot have atomic RmW ops like !ARC_HAS_LLSC.
Mixing cmpxchg()/xchg() with regular stores is broken on those.
Fwiw, you might want to set ARCH_SUPPORTS_ATOMIC_RMW for ARC_HAS_LLSC.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists