[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAMz4kuJVrav0-aU0CSg8KMEiwFwneZuB6vx53cYu9HDroGJiQg@mail.gmail.com>
Date: Thu, 20 Aug 2015 09:42:05 +0800
From: Baolin Wang <baolin.wang@...aro.org>
To: Sergei Shtylyov <sergei.shtylyov@...entembedded.com>
Cc: Felipe Balbi <balbi@...com>, Mark Brown <broonie@...nel.org>,
Linus Walleij <linus.walleij@...aro.org>,
LKML <linux-kernel@...r.kernel.org>,
Greg KH <gregkh@...uxfoundation.org>,
Peter Chen <peter.chen@...escale.com>, sojka@...ica.cz,
Alan Stern <stern@...land.harvard.edu>, r.baldyga@...sung.com,
yoshihiro.shimoda.uh@...esas.com, linux-usb@...r.kernel.org,
device-mainlining@...ts.linuxfoundation.org, sre@...nel.org,
Dmitry Eremin-Solenikov <dbaryshkov@...il.com>,
David Woodhouse <dwmw2@...radead.org>, sameo@...ux.intel.com,
Lee Jones <lee.jones@...aro.org>,
patches@...nsource.wolfsonmicro.com, linux-pm@...r.kernel.org
Subject: Re: [PATCH v4 3/5] gadget: Support for the usb charger framework
On 19 August 2015 at 20:56, Sergei Shtylyov
<sergei.shtylyov@...entembedded.com> wrote:
> Hello.
>
> On 8/19/2015 12:13 PM, Baolin Wang wrote:
>
>> For supporting the usb charger, it adds the usb_charger_init() and
>> usb_charger_exit() functions for usb charger initialization and exit.
>>
>> Introduce a callback 'get_charger_type' which will implemented by
>> user for usb gadget operations to get the usb charger type.
>>
>> Signed-off-by: Baolin Wang <baolin.wang@...aro.org>
>
> [...]
>
>> diff --git a/include/linux/usb/gadget.h b/include/linux/usb/gadget.h
>> index 755e8bc..44d82f5 100644
>> --- a/include/linux/usb/gadget.h
>> +++ b/include/linux/usb/gadget.h
>> @@ -537,6 +537,7 @@ struct usb_gadget_ops {
>> struct usb_ep *(*match_ep)(struct usb_gadget *,
>> struct usb_endpoint_descriptor *,
>> struct usb_ss_ep_comp_descriptor *);
>> + enum usb_charger_type (*get_charger_type)(struct usb_gadget *);
>
> ^^^ please use space, not tab here
OK.
>
>> };
>>
>> /**
>> @@ -611,6 +612,7 @@ struct usb_gadget {
>> struct usb_otg_caps *otg_caps;
>> struct raw_notifier_head nh;
>> struct mutex lock;
>> + struct usb_charger *uchger;
>
>
> Why not simply call the field 'charger'? :-)
I think 'uchger' is the abbreviation of 'usb charger' which is maybe a
little verbous, I'll change it. Thanks for your comments.
>
> [...]
>
> WBR, Sergei
>
--
Baolin.wang
Best Regards
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists